Bug 35843 - Regression: xrandr doesn't offer all resolutions
Regression: xrandr doesn't offer all resolutions
Status: RESOLVED WONTFIX
Product: xorg
Classification: Unclassified
Component: Driver/intel
unspecified
x86 (IA32) Linux (All)
: medium normal
Assigned To: Chris Wilson
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-31 11:45 UTC by Adrian von Bidder
Modified: 2011-04-27 01:04 UTC (History)
0 users

See Also:


Attachments
dmesg: drm.debug=0xe until X was started (kdm running) (62.45 KB, text/plain)
2011-03-31 23:27 UTC, Adrian von Bidder
no flags Details
Xorg.0.log: drm.debug=0xe until X was started (kdm running) (26.87 KB, text/plain)
2011-03-31 23:32 UTC, Adrian von Bidder
no flags Details
dmesg (104.82 KB, text/plain)
2011-04-05 11:00 UTC, Adrian von Bidder
no flags Details
Xorg.0.log (28.04 KB, text/plain)
2011-04-05 11:00 UTC, Adrian von Bidder
no flags Details
dmesg with new kernel (102.99 KB, text/plain)
2011-04-06 12:25 UTC, Adrian von Bidder
no flags Details
Xorg.0.log (30.95 KB, text/plain)
2011-04-06 12:26 UTC, Adrian von Bidder
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian von Bidder 2011-03-31 11:45:11 UTC
Hi,

Version "unspecified" because I have no idea what version the intel driver version 2:2.14.902-1+exp1 (Debian package) corresponds to.

Connecting my laptop to my projector, I don't get all resolutions the latter is capable of. This used to work just fine on older versions (checked with 2:2.13.0-5, again Debian package version, and other packages had older versions as well.) Especially I miss the projector's native resolution of 1360x768.

Full details: Please see the corresponding report against the Debian package on http://bugs.debian.org/617419; Laptop is an Acer netbook connected via VGA to a Panasonic PT-AX200E. Also in the Debian report are Xorg.0.log and other data from a working and a non-working configuration.
Comment 1 Chris Wilson 2011-03-31 12:33:19 UTC
So it seems that we are not passing on the EDID for the VGA connection. Can you please add drm.debug=0xe to your grub boot parameters and attach the resulting dmesg from boot until X start? And we will take it from there.
Comment 2 Adrian von Bidder 2011-03-31 23:27:48 UTC
Created attachment 45117 [details]
dmesg: drm.debug=0xe until X was started (kdm running)
Comment 3 Adrian von Bidder 2011-03-31 23:32:11 UTC
Created attachment 45118 [details]
Xorg.0.log: drm.debug=0xe until X was started (kdm running)

For both logfiles: nothing attached to the VGA port. If you need it, I can do it with the problematic projector attached. (Not right now, need to be at home for this...)

Funnily enough, I had the laptop attached to a TFT yesterday, where I had the native 1440x900 resolution available. So it seems that the communication with the attached display works in some cases.
Comment 4 Chris Wilson 2011-03-31 23:54:17 UTC
(In reply to comment #3) 
> For both logfiles: nothing attached to the VGA port. If you need it, I can do
> it with the problematic projector attached. (Not right now, need to be at home
> for this...)

Ah, I wasn't going mad then! Please can you repeat this with the problematic projector. I'm interested in seeing what actually happens when we detect the connection and attempt to probe the EDID.
Comment 5 Adrian von Bidder 2011-04-05 11:00:11 UTC
Created attachment 45302 [details]
dmesg

This time:
 * boot
 * log in (kdm)
 * plug in projector
 * activate (via krandrtray)

I waited a bit between the steps, I hope it shows in the log timestamps.
Comment 6 Adrian von Bidder 2011-04-05 11:00:47 UTC
Created attachment 45303 [details]
Xorg.0.log
Comment 7 Chris Wilson 2011-04-05 12:41:44 UTC
So, it looks like we are missing the projector's EDID.

There are a few patches for a very similar issue on drm-intel-staging [http://git.kernel.org/?p=linux/kernel/git/ickle/drm-intel.git], particularly the GMBUS fixes. Is it possible for you to try a kernel built from -staging?
Comment 8 Adrian von Bidder 2011-04-06 00:06:11 UTC
I'll see what I can do, haven't compiled my own kernel in years. (just from git HEAD?)

I'll just use the config from my distribution kernel, or is there anything special I need to disable/enable?
Comment 9 Chris Wilson 2011-04-06 00:20:36 UTC
The commits that I think will help the most have just landed in 2.6.39-rc2, so you might be able to find an experimental kernel with them.
Comment 10 Adrian von Bidder 2011-04-06 12:25:52 UTC
Created attachment 45349 [details]
dmesg with new kernel

Not fixed :-(

This (and the x log) is with drm.debug=0xe in kernel 2.6.39 from drm-intel-staging at commit c97b38bd ("Clear any errors")

At 154.520922, I'm plugging the projector in and at 248.264516 I'm activating it from krandrtray. At around 193.256245, I'm querying it with xrandr (no arguments).

This is still Debian's xserver-xorg-video-intel "2:2.14.902-1+exp1" (Debian version number) -- do I need a newer version of this?

thanks
Adrian
Comment 11 Adrian von Bidder 2011-04-06 12:26:51 UTC
Created attachment 45350 [details]
Xorg.0.log
Comment 12 Chris Wilson 2011-04-06 12:29:06 UTC
(In reply to comment #10)
> This is still Debian's xserver-xorg-video-intel "2:2.14.902-1+exp1" (Debian
> version number) -- do I need a newer version of this?

No, the issue is in the kernel. Until i915.ko can see the EDID, we're lost.
Comment 13 Julien Cristau 2011-04-27 01:04:41 UTC
http://www.debian.org/News/2011/20110423

Closing as a hw specific issue with no reporter anymore :(