Bug 35846 - [SNB] Inspiron n5110 panics after several S4 iterations (memory corruption?)
[SNB] Inspiron n5110 panics after several S4 iterations (memory corruption?)
Status: RESOLVED DUPLICATE of bug 35648
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.6 (2010.12)
x86-64 (AMD64) Linux (All)
: high major
Assigned To: Chris Wilson
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-31 12:40 UTC by Bryce Harrington
Modified: 2011-11-25 11:01 UTC (History)
3 users (show)

See Also:


Attachments
BootDmesg.txt (53.40 KB, text/plain)
2011-03-31 12:41 UTC, Bryce Harrington
no flags Details
CurrentDmesg.txt (19.25 KB, text/plain)
2011-03-31 12:41 UTC, Bryce Harrington
no flags Details
XorgLog.txt (28.92 KB, text/plain)
2011-03-31 12:42 UTC, Bryce Harrington
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2011-03-31 12:40:17 UTC
Forwarding this bug from Ubuntu reporter Colin King:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/746615

[Problem]
Inspiron n5110 panics after several S4 iterations

Call Trace:
  __vunmap
  vfree
  i915_gem_object_put_pages_gtt
  i915_gem_object_unbind
  i915_gem_free_object_tail
  ...

[Original Description]
Running multiple S4 cycles causes a kernel panic.  See attached photo of panic.

This can be reproduced as follows:

sudo fwts s4 --s4-multiple --s4-sleep-delay=30

DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Thu Mar 31 19:07:44 2011
DistUpgraded: Fresh install
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-natty-amd64-20110331-0
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:04b0]
InstallationMedia: Ubuntu 11.04 "Natty" - Build amd64 LIVE Binary 20110331-01:37
MachineType: Dell Inc. Inspiron N5110
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=d8358fb4-a9ee-43da-8ee0-7b3a09db6ded ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/04/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X19
dmi.board.vendor: Dell Inc.
dmi.board.version: X19
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvrX19:bd01/04/2011:svnDellInc.:pnInspironN5110:pvrNotSpecified:rvnDellInc.:rn:rvrX19:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: Inspiron N5110
dmi.product.version: Not Specified
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4git20110322-0ubuntu5
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6
Comment 1 Bryce Harrington 2011-03-31 12:41:28 UTC
Created attachment 45101 [details]
BootDmesg.txt
Comment 2 Bryce Harrington 2011-03-31 12:41:59 UTC
Created attachment 45102 [details]
CurrentDmesg.txt
Comment 3 Bryce Harrington 2011-03-31 12:42:18 UTC
Created attachment 45103 [details]
XorgLog.txt
Comment 4 Bryce Harrington 2011-03-31 12:43:54 UTC
Photo of panic message (too big for bugzilla)
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/746615/+attachment/1960025/+files/DSCF1571.JPG
Comment 5 Chris Wilson 2011-03-31 12:51:41 UTC
Indicative of memory corruption.

Bryce, what's the breakdown on the 2.6.38-7 kernel? Is there a convenient way to know if contains the 2011Q1 patches?

Zhenyu has some patches for some S4 issues at http://people.freedesktop.org/~zhen/snb_desk_suspend_0323/ but cf bug 35648 we know we have some unresolved issues.
Comment 6 Robert Hooker (Sarvatt) 2011-03-31 13:01:28 UTC
(In reply to comment #5)
> Indicative of memory corruption.
> 
> Bryce, what's the breakdown on the 2.6.38-7 kernel? Is there a convenient way
> to know if contains the 2011Q1 patches?
> 
> Zhenyu has some patches for some S4 issues at
> http://people.freedesktop.org/~zhen/snb_desk_suspend_0323/ but cf bug 35648 we
> know we have some unresolved issues.

2.6.38-7 is upstream 2.6.38 when it comes to drm. He did try http://kernel.ubuntu.com/~sarvatt/2011Q1/ to be sure the problem existed there too. It only seems to be happening on that one machine (Inspiron 15R), I haven't been able to reproduce this on an E6420 or a sandybridge vostro.
Comment 7 Eugeni Dodonov 2011-11-25 11:01:17 UTC
I'd say it is a duplicate of bug #35648.

*** This bug has been marked as a duplicate of bug 35648 ***