Bug 35864 - [i965gm] random crud in mesa batchbuffer (-> GPU HANG)
Summary: [i965gm] random crud in mesa batchbuffer (-> GPU HANG)
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Ian Romanick
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-01 04:05 UTC by Bryce Harrington
Modified: 2012-08-13 05:29 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
BootDmesg.txt (49.75 KB, text/plain)
2011-04-01 04:06 UTC, Bryce Harrington
Details
CurrentDmesg.txt (24.07 KB, text/plain)
2011-04-01 04:07 UTC, Bryce Harrington
Details
i915_error_state.txt (770.18 KB, text/plain)
2011-04-01 04:07 UTC, Bryce Harrington
Details
XorgLog.txt (35.28 KB, text/plain)
2011-04-01 04:08 UTC, Bryce Harrington
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2011-04-01 04:05:10 UTC
Forwarding this bug from Ubuntu reporter Смирнов Александр Валериянович:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/745456

[Problem]
[i965gm] GPU lockup (IPEHR: 0x08000008)

[Original Description]
Ubuntu Natty 11.04
xserver-xorg-video-intel 2:2.14.0-4ubuntu4

Time: 1301423306 s 427230 us
PCI ID: 0x2a02
EIR: 0x00000000
PGTBL_ER: 0x00000000
Render command stream:
  ACTHD: 0x0fc09d54
  IPEIR: 0x00000000
  IPEHR: 0x08000008
  INSTDONE: 0xff65fafd
  INSTDONE1: 0x000fffff
  INSTPS: 0x8001e022
  INSTPM: 0x00000000
  seqno: 0x009e3872
  fence[0] = fbe00000fbcd04d
  fence[1] = 605200005c5309d
  fence[2] = f5e60000f5e303d
  fence[3] = fa170000f9e806d
  fence[4] = f8b50000f89602d
  fence[5] = e3440000df4509d
  fence[6] = 40c700003cc809d
  fence[7] = f6250000f62001d
  fence[8] = f62b0000f62601d
  fence[9] = f8e00000f8dd03d
  fence[10] = 574300005743003
  fence[11] = cd410000cc0204d
  fence[12] = fc080000fc0700d
  fence[13] = f8c70000f8c003d
  fence[14] = f88a0000f88500d
  fence[15] = fb720000fb6b03d
Active [204]:

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Chipset: i965gm
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
DRM.card0.HDMI.A.1:
status: disconnected
enabled: disabled
dpms: Off
modes:
edid-base64:
DRM.card0.LVDS.1:
status: connected
enabled: enabled
dpms: On
modes: 1280x800
edid-base64: AP///////wANrxASAAAAAAEQAQOAGhB4CvzFklZTkSYgUFQAAAABAQEBAQEBAQEBAQEBAQEBvBsAoFAgFzAwIDYABaMQAAAYAAAA/gBOMTIxSTMtTDAxCiAgAAAA/gBDTU8KICAgICAgICAgAAAA/gBOMTIxSTMtTDAxCiAgANU=
DRM.card0.VGA.1:
status: disconnected
enabled: disabled
dpms: Off
modes:
edid-base64:
Date: Tue Mar 29 22:28:26 2011
DistUpgraded: Log time: 2011-03-21 13:18:18.443894
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: virtualbox-ose, 4.0.4, 2.6.38-7-generic, i686: installed
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
GraphicsCard:
Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 03) (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. Device [1043:14e2]
Subsystem: ASUSTeK Computer Inc. Device [1043:14e2]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110320)
InterpreterPath: /usr/bin/python2.7
MachineType: ASUSTeK Computer Inc. F9E
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=e3af5234-0995-40af-a196-190e65d3b1d5 ro quiet splash vt.handoff=7
ProcKernelCmdLine_: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=e3af5234-0995-40af-a196-190e65d3b1d5 ro quiet splash vt.handoff=7
RelatedPackageVersions:
xserver-xorg             1:7.6~3ubuntu11
libdrm2                  2.4.23-1ubuntu5
xserver-xorg-video-intel 2:2.14.0-4ubuntu4
Renderer: Unknown
SourcePackage: xserver-xorg-video-intel
Title: [i965gm] GPU lockup
UpgradeStatus: Upgraded to natty on 2011-03-25 (4 days ago)
UserGroups:

dmi.bios.date: 10/01/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 204
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: F9E
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr204:bd10/01/2007:svnASUSTeKComputerInc.:pnF9E:pvr1.0:rvnASUSTeKComputerInc.:rnF9E:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: F9E
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
version.compiz: compiz 1:0.9.4git20110322-0ubuntu5
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6
Comment 1 Bryce Harrington 2011-04-01 04:06:29 UTC
Created attachment 45128 [details]
BootDmesg.txt
Comment 2 Bryce Harrington 2011-04-01 04:07:04 UTC
Created attachment 45129 [details]
CurrentDmesg.txt
Comment 3 Bryce Harrington 2011-04-01 04:07:37 UTC
Created attachment 45130 [details]
i915_error_state.txt
Comment 4 Bryce Harrington 2011-04-01 04:08:00 UTC
Created attachment 45131 [details]
XorgLog.txt
Comment 5 Chris Wilson 2011-04-01 07:22:38 UTC
Hmm, garbage towards the end of a mesa (7.10.1) batch. Looks like a missed write by mesa as opposed to cache-line corruption or similar:


0x0fc09d3c:      0x78080003: 3DSTATE_VERTEX_BUFFERS
0x0fc09d40:      0x00000008:    buffer 0: sequential, pitch 8b
0x0fc09d44:      0x0fc5a000:    buffer address
0x0fc09d48:      0x00000004:    max index
0x0fc09d4c:      0x00000000:    mbz
0x0fc09d50:      0x08000008: MI UNKNOWN
0x0fc09d54: HEAD 0x0fc5a040: MI UNKNOWN
0x0fc09d58:      0x00000004: MI_NOOP
0x0fc09d5c:      0x00000000: MI_NOOP
0x0fc09d60:      0x0fbf8981: MI UNKNOWN


0x0fc5a040 looks to be an address within the current vertex buffer, and there is more than a superficial resemblance to 3DSTATE_VERTEX_BUFFERS, but the other values do not fit.
Comment 6 Eric Anholt 2011-06-08 10:48:29 UTC
We really need some information here on what was being run at the time of failure if we're going to reproduce and fix this.  Also, still hoping for testing results with the rewritten brw_draw_upload.c code like you asked the reporter to try.
Comment 7 Eric Anholt 2012-08-13 05:29:22 UTC
Feedback timeout.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.