Bug 36000 - [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x54000004)
Summary: [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x54000004)
Status: RESOLVED DUPLICATE of bug 34014
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.6 (2010.12)
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Chris Wilson
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-04-05 13:07 UTC by Bryce Harrington
Modified: 2011-04-05 23:05 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
BootDmesg.txt (44.21 KB, text/plain)
2011-04-05 13:08 UTC, Bryce Harrington
no flags Details
CurrentDmesg.txt (4.76 KB, text/plain)
2011-04-05 13:08 UTC, Bryce Harrington
no flags Details
i915_error_state.txt (759.76 KB, text/plain)
2011-04-05 13:09 UTC, Bryce Harrington
no flags Details
XorgLog.txt (24.82 KB, text/plain)
2011-04-05 13:10 UTC, Bryce Harrington
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2011-04-05 13:07:56 UTC
Forwarding this bug from Ubuntu reporter Christian Gbel:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/751239

[Problem]
Probably yet another i915 lockup like bug #34014 but this is a different IPEHR than I've seen before, so forwarding it separately in case it is of interest.

[Original Description]
Testing Xubuntu 11.04 beta1 plus latest updates on my laptop (Centrino Platform) I frequently ran into the following issue: 
When I open a new Window in a Web-Application (Novell-Web-Access in Firefox - clicking on a new e-mail will pop-up a new Window that displays the e-mail) then the Monitor picture freezes. The mouse-pointer can still be moved. 

In this bug it is not possible to move to a terminal, e.g. via Ctr-Alt-F1.  Even the shutdown-button has no effect.
The bug cannot be reproduced reliably but happens 2-3 time per day. 

Compared to Ubuntu 10.10 this is a regression.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-intel 2:2.14.0-4ubuntu6
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Chipset: i915gm
Date: Tue Apr  5 13:13:30 2011
DuplicateSignature: (ESR: 0x00000001 IPEHR: 0x54000004)
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
InterpreterPath: /usr/bin/python2.7
Lsusb:
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Samsung Electronics SX20S
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:
 
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=7ed20c70-2942-42af-891c-0f91fababe13 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg             1:7.6+4ubuntu2
 libdrm2                  2.4.23-1ubuntu6
 xserver-xorg-video-intel 2:2.14.0-4ubuntu6
SourcePackage: xserver-xorg-video-intel
Title: [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x54000004)
UdevDb: Error: [Errno 2] No such file or directory
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:
 
dmi.bios.date: 07/14/2006
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 12ZE
dmi.board.name: SX20S
dmi.board.vendor: Samsung Electronics
dmi.board.version: Revision PR
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Samsung Electronics
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr12ZE:bd07/14/2006:svnSamsungElectronics:pnSX20S:pvrRevisionPR:rvnSamsungElectronics:rnSX20S:rvrRevisionPR:cvnSamsungElectronics:ct1:cvrN/A:
dmi.product.name: SX20S
dmi.product.version: Revision PR
dmi.sys.vendor: Samsung Electronics
Comment 1 Bryce Harrington 2011-04-05 13:08:29 UTC
Created attachment 45312 [details]
BootDmesg.txt
Comment 2 Bryce Harrington 2011-04-05 13:08:47 UTC
Created attachment 45313 [details]
CurrentDmesg.txt
Comment 3 Bryce Harrington 2011-04-05 13:09:06 UTC
Created attachment 45314 [details]
i915_error_state.txt
Comment 4 Bryce Harrington 2011-04-05 13:10:00 UTC
Created attachment 45315 [details]
XorgLog.txt
Comment 5 Chris Wilson 2011-04-05 23:05:54 UTC
The subtlety in this i915_error_state is that the IPEHR is on the implicit flush of switching from 3D -> 2D context. At the heart it is still a tiled 3D blit explosion.

*** This bug has been marked as a duplicate of bug 34014 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.