Bug 36071 - [SNB/IVB]Resume from suspend to disk cause restart
[SNB/IVB]Resume from suspend to disk cause restart
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/Intel
unspecified
x86 (IA32) Linux (All)
: high critical
Assigned To: Chris Wilson
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-08 02:07 UTC by Ouping Zhang
Modified: 2011-10-17 09:36 UTC (History)
6 users (show)

See Also:


Attachments
dmesg in text mode (35.60 KB, text/plain)
2011-04-11 03:22 UTC, Ouping Zhang
no flags Details
dmesg in X mode (35.82 KB, text/plain)
2011-04-11 03:23 UTC, Ouping Zhang
no flags Details
Setting no_console_suspend (126.81 KB, application/octet-stream)
2011-07-25 18:32 UTC, Ouping Zhang
no flags Details
Setting no_console_suspend (126.81 KB, text/plain)
2011-07-25 18:55 UTC, Ouping Zhang
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ouping Zhang 2011-04-08 02:07:42 UTC
System Environment:
--------------------------
Libdrm:         (master)2.4.24-11-gbe8802a9414e85ba07ae257fccadd245fcf7c7b6
Mesa:           (7.10)1fb1012bf124b524b0e8cf741fdcec3ed74a25c3
Xserver:        (master)xorg-server-1.10.0
Xf86_video_intel:  (master)2.14.902-4-g972569f6fd1e14519f46e9f50d2509faf1d0aa55
Kernel: (drm-intel-backport)c94249d2a6911daf74f329e05c42e076af2cd024

Bug detailed description:
-------------------------
doing reliability tests on HuronRiver with the command: echo disk > /sys/power/state, resume from suspend to disk fails after 3 suspend/resume cycles. The issue can be reproduced whatever starting X or not. However, resume from suspend to mem can pass after many suspend/resume cycles.
Comment 1 Gordon Jin 2011-04-10 02:14:40 UTC
Ouping, 

what's the symptom of "fail"? Can you attach dmesg?

does this only happen on drm-intel-backport?

does this happen on x-hnr1 (rev08) or x-hnr3 (rev09)?
Comment 2 Ouping Zhang 2011-04-11 03:22:38 UTC
Created attachment 45470 [details]
dmesg in text mode
Comment 3 Ouping Zhang 2011-04-11 03:23:31 UTC
Created attachment 45471 [details]
dmesg in X mode
Comment 4 Ouping Zhang 2011-04-11 20:25:20 UTC
The issue isn't an regression, which can be reproduced on both x-hnr3(rev09) and x-hnr1(rev08). It also happens on the former kernel versions, which is more easily reproduced on the latest kernel version. 
The symptoms of "fail" are as follows: 
when testing on HuronRiver again and again with the commamd: echo disk > /sys/power/state. 
After 2 suspend/resume circles, I found that the test machine can't resume to the former mode from suspend and it would restart by checking /var/log/messages. If in GNOME mode(compiz is disable), the test machine would return to the text mode after 2 suspend/resume circles, because something cause it restart.
The same issue happens both HuronRiver and SugarBay.

(In reply to comment #1)
> Ouping, 
> what's the symptom of "fail"? Can you attach dmesg?
> does this only happen on drm-intel-backport?
> does this happen on x-hnr1 (rev08) or x-hnr3 (rev09)?
Comment 5 Gordon Jin 2011-05-15 19:54:13 UTC
Chris, any idea? Can you reproduce it?
Comment 6 Jesse Barnes 2011-06-16 11:05:31 UTC
Does netconsole give you anything more interesting on the failed resume?  Setting no_console_suspend may get more info out...
Comment 7 meng 2011-06-16 19:43:59 UTC
The problem also exists on our IvyBridge .
Comment 8 Chris Wilson 2011-07-18 07:54:08 UTC
This is another one where the SNB S4 errata seems relevant.
Comment 9 Ouping Zhang 2011-07-25 18:31:58 UTC
Jesse, after resuming from suspend to disk about 40 times, this issue can be reproduced. Setting no_console_suspend in /boot/grub/grub.conf, I get more info on the failed resume, please check the attached Setting no_console_suspend.log

System Environment:
--------------------------
Libdrm:         (master)2.4.26-2-gce317a6d09bb93cff73703b06e5a5bc3cc0b1c6a
Mesa:           (master)4c84acc86fce5eda0aabcb8aa362fd6b5e6a28f6
Xserver:        (master)xorg-server-1.10.99.901-115-g73864a87aacbce85b520ccaa6e360b82c0e99716
Xf86_video_intel:  (master)2.15.0-205-g6dbbb74bde034f5f00aee0396ccd1e03a6625fbd
Kernel: (drm-intel-next)df7976797fa9af161690dbf4dee81ed92cdc150f

 (In reply to comment #6)
> Does netconsole give you anything more interesting on the failed resume? 
> Setting no_console_suspend may get more info out...
Comment 10 Ouping Zhang 2011-07-25 18:32:40 UTC
Created attachment 49546 [details]
Setting no_console_suspend
Comment 11 Ouping Zhang 2011-07-25 18:55:46 UTC
Created attachment 49547 [details]
Setting no_console_suspend
Comment 12 Ouping Zhang 2011-07-25 18:59:40 UTC
The attached can be read by vi.
(In reply to comment #11)
> Created an attachment (id=49547) [details]
> Setting no_console_suspend
Comment 13 Stefan Dirsch 2011-08-29 09:56:38 UTC
(In reply to comment #8)
> This is another one where the SNB S4 errata seems relevant.

Chris, when does Intel plan to address this issue? Can you give us more details about this known SNB S4 errata?
Comment 14 Eugeni Dodonov 2011-10-10 14:09:17 UTC
Hi,

Could you please check if those issues happen if you disable modesetting (e.g., boot with 'nomodeset' kernel parameter)?
Comment 15 Eugeni Dodonov 2011-10-17 09:36:03 UTC
This was fixed on SNB with latest kernel according to testing by Xun Fang, so closing. Please reopen if it is still alive or affects any other system.