Bug 3612 - i810 Driver and/or DRI cause hang on suspend under 2.6.12, xorg 6.8.2
Summary: i810 Driver and/or DRI cause hang on suspend under 2.6.12, xorg 6.8.2
Status: RESOLVED DUPLICATE of bug 3613
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 6.8.2
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Alan Hourihane
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-23 23:42 UTC by Michael Paik
Modified: 2005-06-23 09:00 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description Michael Paik 2005-06-23 23:42:45 UTC
Kernel: 2.6.12
Platform: x86 Intel Centrino
Model: IBM Thinkpad X40
Xorg: 6.8.2 [FC4 RPM]
DRI-Common: 20050621 Snapshot
DRI-i915: 20050621 Snapshot
i810 Xorg Driver: included with DRI-i915 snapthot

Upon suspend (ACPI suspend to RAM), system hangs. If I revert to the i810 driver
included in the xorg 6.8.2 RPM, which deactivates DRI due to libdri version
mismatch (4.3.0 needed, 5.0.0 found) the system suspends cleanly. Various other
snapshots from the last 3 months of the i810 xorg driver show the same problem.
I will cross-post this bug under DRI as well.

For some reason, /var/log/messages isn't logging the oops (it logs some other
call trace from a warning) so I'll have to type this manually from the artifact
left on the screen on hang:

EIP is at i915_set_dpms+0x1c/0x1b2 [i915]
eax: 00000000   ebx: 00000003   ecx: f89d34a2   edx: 00000003
esi: 00000000   edi: 00000003   ebp: 00000003   esp: f7d68ea4
ds: 007b    es: 007b    ss: 0068
Process x40-suspend.sh (pid: 4615, threadinfo=f7d68000 task=f6722550)
Stack: badc0ded f64cc89c c1d8519c 00000000 c021ae4a 00000001 0001c89c 00000000
       00000003 f4488000 00000000 00000003 f89d34e7 00000246 00000003 c1d851e0
       c1d851e0 c1d855ec c1d855ec c021ce7c c028d0ca f7ec8ddc f6360e34 f1e73888
Call Trace:
 [<c021ae4a>] pci_disable_device+0x57/0x63
 [<f89d34e7>] i915_suspend+0x45/0x94 [i915]
 [<c021ce7c>] pci_device_suspend+0x13/0x20
 [<c028d0ca>] suspend_device+0xda/0xe2
 [<c028d190>] device_suspend+0xbe/ox1c2
 [<c014a7b9>] suspend_prepare+0x57/0x85
 [<c014a880>] enter_state+0x2b/0x54
 [<c02470ba>] acpi_system_write_sleep+0x5a/0x6c
 [<c0247060>] acpi_system_write_sleep+0x0/0x6c
 [<c017cbf4>] vfs_write+0x9e/0x110
 [<c017cd11>] sys_write+0x41/0x6a
 [<c0103a51>] syscall_call+0x7/0xb
Code: ff ff 83 c4 18 5b c3 90 90 90 90 90 90 90 90 55 57 56 53 83 ec 1c 89 d7 8b
 b0 00 08 00 00 a1 08 45 db f8 85 c0 0f 85 8d 00 00 00 <8b> 46 04 8b 40 10 c7 80
 c4 03 00 00 01 00 00 00 8b 4e 04 8b 51
Comment 1 Michael Paik 2005-06-23 23:45:07 UTC
*** Bug 3613 has been marked as a duplicate of this bug. ***
Comment 2 Alan Hourihane 2005-06-24 02:00:56 UTC

*** This bug has been marked as a duplicate of 3613 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.