Bug 36126 - xdg-open "waits" on LXDE
Summary: xdg-open "waits" on LXDE
Status: RESOLVED DUPLICATE of bug 16295
Alias: None
Product: Portland
Classification: Unclassified
Component: xdg-utils (show other bugs)
Version: 1.1.0 rc1
Hardware: Other All
: medium normal
Assignee: Portland Bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-11 00:41 UTC by snafu
Modified: 2011-04-14 14:15 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description snafu 2011-04-11 00:41:45 UTC
I use xdg-open 1.1.0 rc1 on a Linux Mint 10 LXDE system. When running it on Ubuntu 10.10 (Gnome) before, xdg-open did immediately exit after the specified file had been opened, but now it waits until the file type's associated program has been exited. That behaviour is a bit annoying, since I rely on xdg-open functionality (in particular: its exit code) inside a project and so it makes my program block on LXDE until the user closes the invoked program. It should not be a LXDE problem, since calling pcmanfm directly works as expected. It would be fine if that could be fixed, so that I don't need to implement some kind of ugly workaround for that. :-)
Comment 1 snafu 2011-04-13 22:47:47 UTC
Found the reason: DE detection doesn't work here. Linux Mint is putting the value ``Mint`` to ``$DESTOP_SESSION``, while xdg-open checks for ``LXDE``.
Comment 2 Rex Dieter 2011-04-14 07:36:30 UTC
waiting or not is dependant upon the helpers used, so I wouldn't assume behavior either way, see also bug #16295

*** This bug has been marked as a duplicate of bug 16295 ***
Comment 3 snafu 2011-04-14 14:15:57 UTC
There still is the issue about LXDE detection. Should I better separate this into a new bug?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.