Bug 36135 - Latin letters with dot above are broken at up to 12px sizes
Summary: Latin letters with dot above are broken at up to 12px sizes
Status: RESOLVED FIXED
Alias: None
Product: DejaVu
Classification: Unclassified
Component: Sans (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Deja Vu bugs
QA Contact:
URL:
Whiteboard:
Keywords:
: 40484 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-11 08:38 UTC by Marius Mikucionis
Modified: 2012-06-09 13:59 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
lower case letters with dot above (7.61 KB, image/png)
2011-04-11 08:38 UTC, Marius Mikucionis
Details
dejavu 2.33 bug (42.33 KB, image/png)
2012-02-24 14:48 UTC, lukasas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marius Mikucionis 2011-04-11 08:38:08 UTC
Created attachment 45479 [details]
lower case letters with dot above

In Bold and Oblique versions of DejaVu Sans, lower case Latin letters with dot above are broken at up to 13pt sizes -- the dot is replaced with a vertical stick.

Examples include letters such as:
zdotaccent U+017C ż LATIN SMALL LETTER Z WITH DOT ABOVE (popular in Polish text)
edotaccent U+0117 ė LATIN SMALL LETTER E WITH DOT ABOVE (popular in Lithuanian text)

More affected uses can be found here:
http://en.wikipedia.org/wiki/Dot_%28diacritic%29

Originally this has been reported here (there is also a picture demonstrating the problem):
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=618310
Comment 1 ultr 2011-05-05 13:11:44 UTC
Very annoying bug.

The problem was not present in version 2.31.
Comment 2 Seán de Búrca 2011-09-26 23:45:55 UTC
I ran a bisect and found that this commit is the culprit:

http://dejavu.svn.sourceforge.net/viewvc/dejavu?view=revision&revision=2446

Reverting the U+0307 / U+02D9 changes would presumably fix the problem. Aside from the hinting fix, looking at the Unicode data, it looks like U+02D9 and U+0307 should be identical in terms of glyph, which they aren't. (The only difference is that the latter is a combining form and the former isn't.)
Comment 3 ultr 2011-11-04 16:06:30 UTC
*** Bug 40484 has been marked as a duplicate of this bug. ***
Comment 4 ultr 2011-11-04 16:08:46 UTC
Any progress on this?
DejaVu is pretty unusable for great number of users now.
Comment 5 Ben Laenen 2011-11-06 11:01:56 UTC
I've now fixed this bug, looks like there were some errors in the hinting instructions...

Please test if all works well now.
Comment 6 Ben Laenen 2011-11-06 11:04:41 UTC
Small addition: the fix is in SVN, so you'll have to check it out there if you know how, or wait for the next snapshot at http://dejavu.sourceforge.net/snapshots/

(and sorry for the slow response time :-) )

Greetings
Ben
Comment 7 Marius Mikucionis 2011-11-15 12:21:29 UTC
I've copied the *.ttf files from this:
http://dejavu.sourceforge.net/snapshots/dejavu-fonts-ttf-2.33-20111115-2495.zip

to /usr/share/fonts/truetype/ttf-dejavu/ on my Debian installation (overwriting the original files of ttf-dejavu-core and ttf-dejavu-extra)

and the issue is gone, I can't replicate it anymore.

Thank you!
Comment 8 lukasas 2012-02-24 14:47:17 UTC
Looks like at least "ż" (small 'z' with dot) is still broken, it occurs only in cursive up to 12pt size (strangely cursive and bolded at the same time is not affected) - added attachment 

ttf-dejavu 2.33
Comment 9 lukasas 2012-02-24 14:48:45 UTC
Created attachment 57611 [details]
dejavu 2.33 bug
Comment 10 Ben Laenen 2012-02-25 02:02:27 UTC
We didn't have a new release yet that includes the bug fix. Download the latest version at http://dejavu.sourceforge.net/snapshots/ and install that one. This will be fixed in 2.34 when it gets out.

I hope to make a new release in a few weeks time, but for now I just have too much work...
Comment 11 lukasas 2012-02-25 03:50:07 UTC
Oh, Sorry for trouble. I thought 2.33 was release aimed to fix that. Regards.
Comment 12 ultr 2012-06-09 13:59:22 UTC
@Ben Laenen

> I hope to make a new release in a few weeks time,
> but for now I just have too much work...

Are there any chances for a release in the nearest future, so that the fix for this bug can go in before Debian Wheezy freezing?

Regards.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.