Bug 3622 - X.org 6.8.2 server dies on startup with signal 11 (ATI Radeon Mobility M6 LY)
Summary: X.org 6.8.2 server dies on startup with signal 11 (ATI Radeon Mobility M6 LY)
Status: RESOLVED DUPLICATE of bug 3227
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 6.8.2
Hardware: x86 (IA32) OpenBSD
: high enhancement
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords: want-backtrace
Depends on:
Blocks:
 
Reported: 2005-06-25 07:36 UTC by Daniel Stone
Modified: 2005-09-27 16:07 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
copy of my /etc/X11/xorg.conf file (2.57 KB, text/plain)
2005-09-11 07:12 UTC, Jonathan Thornburg
no flags Details
copy of /var/log/Xorg.0.log when running X server under gdb (24.08 KB, text/plain)
2005-09-11 07:13 UTC, Jonathan Thornburg
no flags Details
gdb log (including traceback) from running X server (2.09 KB, text/plain)
2005-09-11 07:15 UTC, Jonathan Thornburg
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description FreeDesktop Bugzilla Database Corruption Fix User 2005-06-25 07:36:17 UTC
Summary
=======
OpenBSD 3.7, X.org 6.8.2, Fujitsu/Siemens E6646 i686 laptop,
ATI Radeon Mobility M6 LY video chipset.  The problem is that the X server
crashes on startup with a signal 11.  XFree86 4.3.99.902 works fine
on the same system.

Details
=======
I am using a Fujitsu/Siemens E6646 Lifebook i686 laptop.
The video chipset is an ATI Radeon Mobility M6 LY.
I have just (re)installed OpenBSD 3.7 (which includes X.org 6.8.2)
on this system.

The problem is that the X server crashes on startup with a signal 11.
I have tried a number of different ways of generating /etc/X11/xorg.conf
but all give the same behavior (signal 11 crash on startup):
* xorgcfg
* X -configure
* xorgcfg -textmode
* copy working XFree86 XF86Config for this same system (see below)

Attached are an OpenBSD 'dmesg' (showing the video & other hardware
as detected by the kernel), an /etc/X11/xorg.conf, and the /var/log/Xorg.0.log
from 'startx' with that xorg.conf.

The same system (booting from a different disk partition) runs
OpenBSD 3.5-stable's XFree86 4.3.99.902 fine (attached are the 3.5-stable
dmesg, /usr/X11R6/lib/X11/XF86Config, and /var/log/XFree86.0.log).
Comment 1 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-25 07:37:52 UTC
Created attachment 2957 [details]
GPG pubkey
Comment 2 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-25 07:47:54 UTC
Created attachment 2958 [details] [review]
Simplify Imakefiles and fix build (bad)
Comment 3 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-25 07:49:15 UTC
Created attachment 2959 [details] [review]
Proposed patch
Comment 4 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-25 07:50:20 UTC
Created attachment 2960 [details] [review]
fix version check
Comment 5 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-25 07:55:03 UTC
Created attachment 2961 [details]
Xorg log file

As noted in the bug text, OpenBSD 3.5's XFree86 4.3.99.902 works fine
on the same system.  This attachment shows the OpenBSD 3.5 kernel's
detection of hardware (including the video chipset).
Comment 6 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-25 07:56:36 UTC
Created attachment 2962 [details] [review]
Patch I'm applying

This is the /usr/X11R6/lib/X11/XF86Config file
I use for OpenBSD 3.5's XFree86 4.3.99.902 on this
same system (which works fine).
Comment 7 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-25 07:58:01 UTC
Created attachment 2963 [details] [review]
Proposed patch
Comment 8 Adam Jackson 2005-07-03 14:46:00 UTC
starting with the 6.8.99.14 snapshot, on linux systems, the X server can print
its own backtrace when it crashes.  please confirm that these bugs are still
valid with 6.8.99.14 or later, and if they are please attach a the server log
from the crash.
Comment 9 Karl Sjödahl 2005-07-19 02:43:36 UTC
I have the same problem with a ATI Radeon IGP 340M card and OpenBSD.
Today I tryed to compile a snapshot on OpenBSD 3.7-current (from 22 june).
6.8.99.15 and 6.8.99.14 won't compile on OpenBSD but 6.8.99.13 compiled.
It has the same problems and the only warning I get is:
(WW) RADEON(0): LCD DDC Info Table found!

and then the same:
Fatal server error:
Caught signal 11. Server aborting.
Comment 10 Jonathan Thornburg 2005-09-11 07:12:55 UTC
Created attachment 3228 [details]
copy of my /etc/X11/xorg.conf file
Comment 11 Jonathan Thornburg 2005-09-11 07:13:35 UTC
Created attachment 3229 [details]
copy of /var/log/Xorg.0.log when running X server under gdb
Comment 12 Jonathan Thornburg 2005-09-11 07:15:13 UTC
Created attachment 3230 [details]
gdb log (including traceback) from running X server

This is the gdb log when following the instructions on
   http://wiki.x.org/wiki/DebuggingTheXserver
in the section "Debugging with one machine", subsection "Version 1".

Unfortunately, it seems my X server was built with only limited
debugging symbols, so many addresses aren't resolved. :( :(
Comment 13 Jonathan Thornburg 2005-09-11 07:21:08 UTC
I realise that the gdb traceback I've just submitted isn't very useful
(not enough debugging symbols in the X server binary).

I will try to compile a new X server from source with full -g debugging support,
and if successful, I'll submit a new (& hopefully more informative) gdb traceback.
Comment 14 Adam Jackson 2005-09-28 09:07:42 UTC

*** This bug has been marked as a duplicate of 3227 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.