Bug 36374 - The game Enemy Territory: Quake Wars crashes
The game Enemy Territory: Quake Wars crashes
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
git
x86 (IA32) Linux (All)
: medium minor
Assigned To: Eric Anholt
: NEEDINFO
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-18 21:29 UTC by Md Imam Hossain
Modified: 2011-06-23 22:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Screenshot of the problem (65.87 KB, image/jpeg)
2011-04-20 03:33 UTC, Md Imam Hossain
Details
Screenshot 1 of the problem (81.73 KB, image/jpeg)
2011-04-20 03:34 UTC, Md Imam Hossain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Md Imam Hossain 2011-04-18 21:29:43 UTC
Mesa 7.11-devel cloned from git as of today 19th April 2011
Ubuntu 10.10
Linux 2.6.36-02063604-generic
Intel GMA 4500 256MB

Sky is broken in the game Enemy Territory: Quake Wars.
To reproduce start Campaign Africa in the game.

glxinfo | grep OpenGL
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
OpenGL version string: 2.1 Mesa 7.11-devel (git-f41e1db)
OpenGL shading language version string: 1.20
OpenGL extensions:

Thanks
Comment 1 Ian Romanick 2011-04-19 16:27:35 UTC
This sounds like bug #34628.  Is it the same issue?
Comment 2 Md Imam Hossain 2011-04-20 03:33:32 UTC
Created attachment 45855 [details]
Screenshot of the problem
Comment 3 Md Imam Hossain 2011-04-20 03:34:04 UTC
Created attachment 45856 [details]
Screenshot 1 of the problem
Comment 4 Md Imam Hossain 2011-04-21 06:04:57 UTC
(In reply to comment #1)
> This sounds like bug #34628.  Is it the same issue?

Tested quake 4 with git, there is no such problem.
But the sky is still broken in the game Enemy Territory: Quake Wars.

Intel GMA 4500 256MB
Linux 2.6.36-02063604-generic
Ubuntu 10.10

glxinfo | grep OpenGL

OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
OpenGL version string: 2.1 Mesa 7.11-devel (git-08ba977)
OpenGL shading language version string: 1.20
OpenGL extensions:
Comment 5 Md Imam Hossain 2011-05-27 04:12:31 UTC
this bug is introduced by the commit:

559435d9152acc7162e4e60aae6591c7c6c8274b

http://cgit.freedesktop.org/mesa/mesa/commit/?id=559435d9152acc7162e4e60aae6591c7c6c8274b

after having a look at the patch, I guess this is something to do with gen5 if condition.

Please, dont confuse this bug with other bugs.

Thank you
Comment 6 Md Imam Hossain 2011-06-23 18:59:10 UTC
this bug is duplicate of the bug

https://bugs.freedesktop.org/show_bug.cgi?id=37934

according to bisect
Comment 7 Md Imam Hossain 2011-06-23 19:41:00 UTC
commits

vbo: Don't bother checking for stride == 0 for "any varying in a VBO".
http://cgit.freedesktop.org/mesa/mesa/commit/?id=8f28c05d07c7a1919c938d81b5f524aed2c60228

and

vbo: Don't discount stride == 0 for testing all varyings in VBOs.
http://cgit.freedesktop.org/mesa/mesa/commit/?id=d631c19db47181129811080bfa772b210d762d4d

fix graphical corruption in the game but the game now keeps crashing after few seconds of getting into the stage.

terminal output:

--------------------------------------
------------- Initialized in 08 -------------
--- Common Initialization Complete ---
terminal support enabled ( use +set in_tty 0 to disabled )
pid: 18687
2200 MHz CPU
2992 MB System Memory
detecting video ram (set sys_videoRam on command line to override) ..
trying /proc/dri/0/umm
guess failed, return default low-end VRAM setting ( 128MB VRAM )
128 MB Video Memory
Async thread started
Opening IP socket: localhost:-1
checking /home/emamg/.etqw/ETQW-demo-client-1.4-full.x86.run...
update file downloaded to /home/emamg/.etqw/ETQW-demo-client-1.4-full.x86.run is corrupted, removing
A new version of the Enemy Territory: Quake Wars demo is available. Download now?
Download Now - Go to website
downloading ETQW-demo-client-1.4-full.x86.run: 0.0%
curl_easy_perform failed: Callback aborted
download failed: curl errcode 42, error Callback aborted
couldn't exec '/home/emamg/.etqw/sdnet/emam/base/autoexec.cfg'
execing /home/emamg/.etqw/sdnet/emam/base/profile.cfg 
execing 'localization/english/defaultbinds.cfg'
execing /home/emamg/.etqw/sdnet/emam/base/bindings.cfg 
Opening IP socket: localhost:27733
Server spawned on port 27733.
client 0 connected.
WARNING: renderProg 'trivialrgbskinningmatrix' is defaulted
WARNING: renderProg 'trivialrgbhardskinningmatrix' is defaulted
--------- Map Initialization ---------
Map: maps/valley.entities
WARNING: Sys_Sleep - 10 < 20 msec is not portable
----------- Game Map Init ------------
found DLL in pak file: /home/emamg/Downloads/etqw/base/game002.pk4/compiledscriptx86.so
copy compiledscriptx86.so to /home/emamg/.etqw/base/compiledscriptx86.so
Loaded '/home/emamg/.etqw/base/compiledscriptx86.so'
  262 classes
  80 global functions
----------- Loading Map AAS ------------
[Load AAS Binary]
loading 'maps/valley.aas_playerb'
[Load AAS Binary]
loading 'maps/valley.aas_vehicleb'
collision data:
   129 models
255044 vertices (2988 kB)
403265 edges (7876 kB)
182566 polygons (11410 kB)
595042 polygon edges (1162 kB)
  2798 brushes (87 kB)
 16813 brush planes (262 kB)
 86283 nodes (2359 kB)
386936 polygon refs (3022 kB)
  3453 brush refs (26 kB)
103114 internal edges
   843 sharp edges
     0 contained polygons removed
     0 polygons merged
 29412 kB total memory used
510 msec to load collision data.
    3 KB passage memory used to build PVS
    2 msec to calculate PVS
   54 areas
  120 portals
    7 areas visible on average
  432 bytes PVS data
Spawning entities
Loaded 'stuff/valley/stuff.clustb' in 0.3 seconds
...991 entities spawned, 0 inhibited

----------- Loading Map Bot Actions ------------
--------------------------------------
thread priority set to 2
----- idRenderModelManagerLocal::EndLevelLoad -----
    0 purged from previous
 1446 kept from previous
  469 new loaded
all models loaded in   0.0 seconds
---------------------------------------------------
----- idImageManager::EndLevelLoad -----
    0 purged from previous
   99 kept from previous
 1283 new loaded
    0 megaTextures purged from previous
    1 megaTextures kept from previous
all images loaded in   1.3 seconds
----------------------------------------
----- idSoundCache::EndLevelLoad -----
41074k referenced
    0k purged
----------------------------------------
-----------------------------------
 17538 msec to load maps/valley.entities
interactionTable size: 1106708 bytes
0 interaction take 0 bytes
Loaded map in    18 seconds
SpawnPlayer: 0
Emam entered the game.
client 1 connected.
SpawnPlayer: 1
Herr Boehme entered the game.
Herr Boehme joined the Strogg
idUsercmdGenLocal::MouseMove: Ignoring ridiculous mouse delta.
idUsercmdGenLocal::MouseMove: Ignoring ridiculous mouse delta.
idUsercmdGenLocal::MouseMove: Ignoring ridiculous mouse delta.
idUsercmdGenLocal::MouseMove: Ignoring ridiculous mouse delta.
client 2 connected.
SpawnPlayer: 2
I'm a bot entered the game.
I'm a bot joined the GDF
Emam joined the GDF
client 3 connected.
SpawnPlayer: 3
Washout entered the game.
Washout joined the Strogg
Segmentation fault
Comment 8 Md Imam Hossain 2011-06-23 22:52:14 UTC
Strange, restarted the system, removed config directory .etqw from home directory and started the game and set all graphics options like before and boom no more crash from initial testing!

closing this bug for now, will reopen if the problem arises again.