Bug 36456 - [piketon] DP hotplug will let system down
Summary: [piketon] DP hotplug will let system down
Status: VERIFIED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high critical
Assignee: Chris Wilson
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 36561 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-21 02:42 UTC by bo.b.wang
Modified: 2011-06-06 20:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
DP hotplug infomation (1.22 KB, text/plain)
2011-04-21 02:44 UTC, bo.b.wang
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bo.b.wang 2011-04-21 02:42:56 UTC
System Environment:
--------------------------
kernel keith tree (drm-intel-fixes)commit:5c72d064f7ead1126bed6faab0c2bfb7418036e2
platform  piketon
VGA + DP interface

Bug detailed description:
-------------------------
After Hotplug DP interface some times. Messages from syslogd exist in the console and then system down.Attachment is messages from console.
this issue exists 2.6.39-rc2 (commit 6221f222c0ebf1acdf7abcf927178f40e1a65e2a)


Reproduce steps:
----------------
1.with DP + VGA interface 
2.hotplug DP interface some times
Comment 1 bo.b.wang 2011-04-21 02:44:41 UTC
Created attachment 45911 [details]
DP hotplug infomation
Comment 2 Chris Wilson 2011-04-21 02:46:42 UTC
Look in dmesg for the complete OOPS.
Comment 3 Chris Wilson 2011-04-21 02:48:58 UTC
At a guess:

commit fea4e9038079ae3300eddde50ab258e5b43c693f
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Sun Apr 17 06:38:35 2011 +0100

    drm/i915/dp: Be paranoid in case we disable a DP before it is attached
    
    Given that the hardware may be left in a random condition by the BIOS,
    it is conceivable that we then attempt to clear the DP_PIPEB_SELECT bit
    without us ever enabling/attaching the DP encoder to a pipe. Thus
    causing a NULL deference when we attempt to wait for a vblank on that
    crtc.
    
    Reported-and-tested-by: Bryan Christ <bryan.christ@gmail.com>
    References: https://bugs.freedesktop.org/show_bug.cgi?id=36314
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Cc: stable@kernel.org
Comment 4 bo.b.wang 2011-04-21 19:11:56 UTC
(In reply to comment #2)
> Look in dmesg for the complete OOPS.

This issue will let system down. I can't ssh to fetch dmesg
Comment 5 bo.b.wang 2011-04-21 20:35:04 UTC
(In reply to comment #3)
> At a guess:
> 
> commit fea4e9038079ae3300eddde50ab258e5b43c693f
> Author: Chris Wilson <chris@chris-wilson.co.uk>
> Date:   Sun Apr 17 06:38:35 2011 +0100
> 
>     drm/i915/dp: Be paranoid in case we disable a DP before it is attached
> 
>     Given that the hardware may be left in a random condition by the BIOS,
>     it is conceivable that we then attempt to clear the DP_PIPEB_SELECT bit
>     without us ever enabling/attaching the DP encoder to a pipe. Thus
>     causing a NULL deference when we attempt to wait for a vblank on that
>     crtc.
> 
>     Reported-and-tested-by: Bryan Christ <bryan.christ@gmail.com>
>     References: https://bugs.freedesktop.org/show_bug.cgi?id=36314
>     Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
>     Cc: stable@kernel.org

There is another testdisplay issue that seems to https://bugs.freedesktop.org/show_bug.cgi?id=36314. But , I can't get that commit in stable or unstable kernel.
So, Would you like to tell me how can I get that commit?
Your reply will be appreciated
Comment 6 Chris Wilson 2011-04-21 22:23:19 UTC
Now ickle/drm-intel-staging commit 8ff887c847a8c88cee2cddffb8b94f41ebd5e4db
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Sun Apr 17 06:38:35 2011 +0100

    drm/i915/dp: Be paranoid in case we disable a DP before it is attached
Comment 7 bo.b.wang 2011-04-25 00:07:05 UTC
(In reply to comment #6)
> Now ickle/drm-intel-staging commit 8ff887c847a8c88cee2cddffb8b94f41ebd5e4db
> Author: Chris Wilson <chris@chris-wilson.co.uk>
> Date:   Sun Apr 17 06:38:35 2011 +0100
> 
>     drm/i915/dp: Be paranoid in case we disable a DP before it is attached

Hi Chris, I have tested this commit.And DP hotpluging is no problem.
Comment 8 bo.b.wang 2011-04-26 01:30:24 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Now ickle/drm-intel-staging commit 8ff887c847a8c88cee2cddffb8b94f41ebd5e4db
> > Author: Chris Wilson <chris@chris-wilson.co.uk>
> > Date:   Sun Apr 17 06:38:35 2011 +0100
> > 
> >     drm/i915/dp: Be paranoid in case we disable a DP before it is attached
> 
> Hi Chris, I have tested this commit.And DP hotpluging is no problem.
Tested-by: Wang Bo <bo.b.wang@intel.com>
Comment 9 Chris Wilson 2011-04-27 04:11:19 UTC
*** Bug 36561 has been marked as a duplicate of this bug. ***
Comment 10 Gordon Jin 2011-05-19 06:32:54 UTC
The commit should have been pushed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.