Bug 36473 - [bisected] piglit bugs/fdo23670-depth_test failed
Summary: [bisected] piglit bugs/fdo23670-depth_test failed
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: All Linux (All)
: high major
Assignee: Ian Romanick
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-21 21:28 UTC by fangxun
Modified: 2011-05-02 20:18 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fangxun 2011-04-21 21:28:14 UTC
System Environment:
--------------------------
Arch:           x86-64
Platform:       piketon 
Libdrm:         (master)2.4.25
Mesa:           (master)08ba9778dbf3326bdfc8ca8035b51412032748ea
Xserver:      (master)xorg-server-1.10.0-210-gb3d2164a0361f636bfe77b51456bee9213af4f13
Xf86_video_intel:(master)2.15.0-5-g0944e2d5749f5122cd9802c4a2421106fa829ea4
Kernel: (drm-intel-next)daab1470018f025e0b1c8731dfb825ff421ffd9b

Bug detailed description:
-------------------------
Many piglit and oglc cases failed due to mesa master commit: b2491972591788fea0e55805cea3e9be8760969b. It happens on pineview, ironlake and sandybridge.
 
piglit failed cases: bugs/fdo23670-depth_test, fbo/fbo-fragcoord2,
fbo/fbo-readdrawpix, general/pbo-drawpixels, glean/pboBisect, texturing/texture-al.
oglc failed cases: apfunc, zbfunc, logicop, drawpix, packpix, pxconv-draw, api-rasterpos, pixel-invar, ....

Bisect shows b2491972591788fea0e55805cea3e9be8760969b is the first bad commit.
ommit b2491972591788fea0e55805cea3e9be8760969b
Author:     Eric Anholt <eric@anholt.net>
AuthorDate: Fri Apr 15 15:48:32 2011 -0700
Commit:     Eric Anholt <eric@anholt.net>
CommitDate: Wed Apr 20 10:35:42 2011 -0700

    meta: Add support for ARB_color_buffer_float to _mesa_meta_DrawPixels.

    Tested with piglit arb_color_buffer_float-drawpixels.

    Reviewed-by: Brian Paul <brianp@vmware.com>


Reproduce steps:
-------------------------
1. start X
2. ./fdo23670-depth_test -auto
Comment 1 Eric Anholt 2011-04-29 12:32:28 UTC
commit 8c1637a4c233fd02a57dee1e38ac87012a04c4c5
Author: Eric Anholt <eric@anholt.net>
Date:   Tue Apr 26 12:56:37 2011 -0700

    meta: Don't ask for floating point textures if not ARB_texture_float.
    
    I was promoting to float for ARB_color_buffer_float unclamped, which
    failed when ARB_texture_float wasn't present.  Since the metaops don't
    need results outside of [0,1] when not drawing to a floating point
    destination, they can just use a fixed point texture when floating
    point destinations are impossible.
    
    Fixes regression in fdo23670-depth_test when --enable-texture-float is
    not present.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=36473
Comment 2 fangxun 2011-05-02 20:18:53 UTC
Verified with mesa master 929b3d82334e217641c3f39e7914a90dadc6e6b2.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.