Bug 3654 - Unable to obtain the right resolution for DVI panel
Unable to obtain the right resolution for DVI panel
Status: RESOLVED WONTFIX
Product: xorg
Classification: Unclassified
Component: Driver/nVidia (open)
6.8.2
x86 (IA32) Linux (All)
: high normal
Assigned To: Xorg Project Team
Xorg Project Team
:
: 4314 5400 7865 16085 17828 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-29 00:28 UTC by Daniel Stone
Modified: 2008-09-29 14:58 UTC (History)
13 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FreeDesktop Bugzilla Database Corruption Fix User 2005-06-29 00:28:23 UTC
I have a Sony HX93 monitor with a DVI connection.
The right resolution for this monitor is 1280 x 1024.

With nvidia binary driver, I can use this resolution without any trouble.
With xorg nv driver, this resolution is unavailable.

Xorg.log file :
(II) NV(0): Mode "1280x1024" is larger than BIOS programmed panel size of 1024 x
768.  Removing.

Version-Release number of selected component (if applicable):
Fedora Core 4 - xorg-x11-6.8.2-37

I have created a bug report in redhat bugzilla
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=160893), but they asked me
to report the issue to X.Org.
Comment 1 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-29 00:31:27 UTC
Created attachment 2989 [details] [review]
Use system method for all accesses
Comment 2 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-29 00:33:54 UTC
Created attachment 2990 [details]
public PGP key for int-e@gmx.de
Comment 3 Andreas Hauser 2005-08-19 13:59:21 UTC
The original submitter opened a redhat bugreport too:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=160893

I have the same probblem on DragonFly and Freebsd (i386/amd64).
It just believes that the panel has a much smaller size and
no matter what Modeline, force of EDIDOff, force of Flatpanel etc. helps.
Using the nvidia.com binaries works fine (but there are non for e.g. FreeBSD/amd64)

(II) NV(0): Monitor name: PHILIPS 200P
(II) NV(0): Ranges: V min: 56  V max: 85 Hz, H min: 30  H max: 92 kHz, PixClock
max 160 MHz
(II) NV(0): Probing for EDID on I2C bus B...
(II) NV(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) NV(0): I2C device "DDC:ddc2" removed.
(II) NV(0):   ... none found
(--) NV(0): CRTC 0 is currently programmed for DFP
(**) NV(0): Forcing display type to DFP as specified
(II) NV(0): Using DFP on CRTC 0
(--) NV(0): Panel size is 1024 x 768
(--) NV(0): VideoRAM: 65536 kBytes
(==) NV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) NV(0): Monitor0: Using default hsync range of 30.00-92.00 kHz
(II) NV(0): Monitor0: Using default vrefresh range of 56.00-85.00 Hz
(II) NV(0): Clock range:  12.00 to 350.00 MHz
(II) NV(0): Mode "1600x1200my" is larger than BIOS programmed panel size of 1024
x 768.  Removing.
(II) NV(0): Not using mode "1600x1200my" (unknown reason)
Comment 4 Andreas Hauser 2005-08-19 14:08:50 UTC
Also discussed here:
http://qa.mandriva.com/show_bug.cgi?id=15713

I used:
    Mode "1600x1200my"
    DotCLock 130.25
    HTimings 1600 1648 1680 1760
    VTimings 1200 1203 1207 1235
    EndMode

But that didn't help.
Comment 5 Samuel Abels 2005-08-25 09:54:23 UTC
I have the exact same problem as the submitter, only with different hardware.

Card:    Nvidia GeForce 6600 GT
Monitor: Samsung SyncMaster 243T, via DVI
xorg:    6.8.2-10 package from Ubuntu Breezy
driver:  nv

I selected screen resolution 1920x1200, but it only works up to 1024x768.

A couple of weeks ago I was using an older version of xorg without any problem
(xorg version unfortunately unknown). The problem appeared after upgrading xorg
through apt. I have not made any changes to the system bios.

When using the proprietary nvidia driver the same problem happens, only that the
error message (Mode "1920x1200" is larger than BIOS programmed panel size of
1024 x 768. Removing.) does not appear.
Comment 6 Samuel Abels 2005-08-25 09:56:16 UTC
Also discussed here:
http://bugzilla.ubuntu.com/show_bug.cgi?id=13884
Comment 7 Samuel Abels 2005-09-02 14:28:33 UTC
I just tested the VGA output of my card, using this one it works. (Well, except
that the image quality of VGA is very poor.) So apparently the problem is
related to DVI/DPMS.
I also tried the "UseModeline" and "FixPanelSize" options in combination with
this modeline:

ModeLine "1920x1200" 200.0 1920 2000 2400 2560 1200 1202 1214 1240 -hsync -vsync

but this didn't change the behavior.
Comment 8 Samuel Abels 2005-09-02 14:32:35 UTC
(Sorry for the noise, but I of course meant DDC rather than DPMS.)
Comment 9 Koos Vriezen 2006-04-07 00:16:11 UTC
Yesterday I lost yet another few hours to get nvidia 8178 driver compiled for 
2.6.16.1 kernel, had to patch it yet again to get it compiling.
And only because of this bug that's here for more than a 3/4 year. Using 
debian/testing w/ xorg-6.9.0 currently, for a 1920x1200 display.
Would be very nice to have nv support this for DVI as well and not force us to 
use the binary only driver.
Comment 10 ajax at nwnk dot net 2006-04-15 05:55:05 UTC
*** Bug 4314 has been marked as a duplicate of this bug. ***
Comment 11 Aaron Plattner 2006-06-12 15:31:00 UTC
Copying and pasting my post from bug 4314:

The "nv" driver currently can't change the BIOS-programmed display timings. 
Unfortunately, this is not something that we can fix right now.
Comment 12 Aaron Plattner 2006-07-03 16:42:32 UTC
*** Bug 5400 has been marked as a duplicate of this bug. ***
Comment 13 Johan Marcusson 2006-07-11 09:37:04 UTC
I also have the same problem, it would be very neat if you could fix it! 
Especially since the nvidia binary driver doesn't work in X.org 7.1.

My system has a GeForce 6600GT with a DELL 2001FP. The resolution should be 
1600x1200 but it's only 1280x1024 with makes the screen very blurry :'(
Comment 14 Scott Lamb 2006-08-19 13:34:07 UTC
Re: comment #8

Aaron, could you please elaborate on "this is not something we can fix right now"? Is this an architectural 
problem with Xorg? A problem of inadequate nvidia documentation? A man-power shortage? Is there 
anything I can do?
Comment 15 Aaron Plattner 2006-08-21 08:04:54 UTC
Scott: I'm afraid I have no additional info.
Comment 16 Aaron Plattner 2006-08-21 08:07:15 UTC
*** Bug 7865 has been marked as a duplicate of this bug. ***
Comment 17 Marijn Schouten 2006-10-17 08:10:58 UTC
1600x1200 seems to be working on my dell 2001FP. I'm using the following:

Section "Monitor"
        Identifier      "RightMonitor"
        Option          "TargetRefresh" "60.0"
EndSection
Comment 18 John King 2006-10-17 16:35:17 UTC
It's completely dependent on if the BIOS sets up the flat panel control/timing
registers for those resolutions, which is it works for some but not for others.

A question for clarification: is this the video card's BIOS?  If so, is there
any way nVidia, or an nVidia employee, could make available a video card BIOS
that does indeed program up the flat panel control registers for large panel
sizes (up to 1600x1200 or 1920x1200, etc.)?  This would of course be completely
unsupported by nVidia, but it would solve the problem...
Comment 19 Daniel Stone 2007-02-27 01:27:12 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 20 Aaron Plattner 2007-03-09 13:12:38 UTC
G80-based cards should be able to program the correct resolution on flat panels with xf86-video-nv 1.99.1 and higher.  This is not something we can implement for earlier GPUs, so marking WONTFIX.
Comment 21 Aaron Plattner 2008-05-26 01:22:23 UTC
*** Bug 16085 has been marked as a duplicate of this bug. ***
Comment 22 Aaron Plattner 2008-09-29 12:21:13 UTC
*** Bug 17828 has been marked as a duplicate of this bug. ***