Bug 36542 - Radeon HD 6570 GPU lockup (waiting for 0x00000281 last fence id 0x00000280)
Radeon HD 6570 GPU lockup (waiting for 0x00000281 last fence id 0x00000280)
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/Radeon
XOrg git
Other All
: medium normal
Assigned To: Default DRI bug account
:
: 37151 38367 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-24 06:18 UTC by Michael Larabel
Modified: 2011-06-28 08:48 UTC (History)
2 users (show)

See Also:


Attachments
dmesg on lockup (64.55 KB, patch)
2011-04-24 06:18 UTC, Michael Larabel
no flags Details | Splinter Review
dmesg from nexuiz, reseting keeps happening (92.37 KB, text/plain)
2011-04-24 06:47 UTC, Michael Larabel
no flags Details
dmesg drm.debug=15 (243.44 KB, text/plain)
2011-04-24 06:48 UTC, Michael Larabel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Larabel 2011-04-24 06:18:32 UTC
Created attachment 46018 [details] [review]
dmesg on lockup

Alex,

Here's the dmesg output I just hit when trying the latest mainline kernel from 24 April on the Radeon HD 6570... I didn't check to see if it's similar to the lockups I've previously talked about for HD 6570 / HD 6850 in a slightly older kernel before the latest DRM merge. For this log attached, the GPU locked up right after starting the GNOME desktop with Compiz, soft reset, and recovered. Running Mesa Git master as of this morning.
Comment 1 Michael Larabel 2011-04-24 06:47:27 UTC
Created attachment 46019 [details]
dmesg from nexuiz, reseting keeps happening

Here's another dmesg output (I have another one at drm.debug=15 I'll post also) that may or may not be the same exact problem (there's some similarities in the trace) as the other one I just posted, but this one is always been reproducible for me running Nexuiz on the HD 6570 and HD 6850 (anything pre-NI works fine in same configuration). When the GPU resets with Nexuiz in this environment, it basically gets stuck in an infinite loop of the GPU soft resetting and never able to properly restore itself.
Comment 2 Michael Larabel 2011-04-24 06:48:31 UTC
Created attachment 46020 [details]
dmesg drm.debug=15
Comment 3 Alex Deucher 2011-05-12 14:23:28 UTC
*** Bug 37151 has been marked as a duplicate of this bug. ***
Comment 4 Dave Airlie 2011-05-25 18:24:02 UTC
are you running nexuiz in any particular way?

I'm wondering if this is TURKS specific, my BARTS can run gnome-shell + nexuiz timedemo demos/demo1.dem in full here with no hangs.
Comment 5 Erdem U. Altınyurt 2011-05-25 18:32:15 UTC
Don't know "nexuiz's timedemo demos/demo1.dem" but my barts (HD6850) hanging up while I am in desktop (with compiz) too. So I don't believe if this is related with just TURKS but BARTS...
Comment 6 Alex Deucher 2011-06-16 07:45:38 UTC
*** Bug 38367 has been marked as a duplicate of this bug. ***
Comment 7 Matt Novenstern 2011-06-25 10:55:51 UTC
Now that I can boot at all with my 6850, I'm getting this bug, too.  Seems to be triggered by 3d, I don't think gnome shell has triggered it alone yet.

Same dmesg.
Comment 9 Matt Novenstern 2011-06-25 15:13:56 UTC
Yes! With the two patches (the vddc one was new - I compiled my first fedora kernel!) everything seems to work fine.  I tested nexuiz and xbmc.

Thank you!
Comment 10 Jerome Glisse 2011-06-28 08:48:00 UTC
Fix in next kernel