Bug 36589 - udisks should verify if /var/run/udisks (localstatedir) exists before trying to use it
udisks should verify if /var/run/udisks (localstatedir) exists before trying ...
Status: RESOLVED DUPLICATE of bug 24265
Product: udisks
Classification: Unclassified
Component: operations
unspecified
Other All
: medium major
Assigned To: David Zeuthen (not reading bugmail)
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-25 12:27 UTC by Samuli Suominen
Modified: 2011-08-26 08:32 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuli Suominen 2011-04-25 12:27:29 UTC
localstatedir (/var/run) can be tmpfs, so udisks shouldn't create any directory to it when running `make install`.
any files on directories created on it will disappear on boot, and it's perfectly legal setup.
it should verify if the directory exists or not, and then create it on-fly instead. 

for reference how this causes problems, see:

https://bugs.gentoo.org/show_bug.cgi?id=364827
https://bugs.gentoo.org/show_bug.cgi?id=333893
Comment 1 David Zeuthen (not reading bugmail) 2011-08-26 08:32:11 UTC

*** This bug has been marked as a duplicate of bug 24265 ***