Bug 37159 - segfault in shadowUpdatePacked triggered by "Virtual 3200 1200"
Summary: segfault in shadowUpdatePacked triggered by "Virtual 3200 1200"
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/fbdev (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL: http://bugs.debian.org/625521
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-12 20:46 UTC by Jonathan Nieder
Modified: 2018-08-10 20:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
X server log exhibiting crash (29.90 KB, text/plain)
2011-05-12 20:46 UTC, Jonathan Nieder
no flags Details
"fbset -i" output (411 bytes, text/plain)
2011-05-12 20:46 UTC, Jonathan Nieder
no flags Details
xorg.conf that triggered it (979 bytes, text/plain)
2011-05-12 20:47 UTC, Jonathan Nieder
no flags Details
full backtrace (3.44 KB, text/plain)
2011-05-12 20:48 UTC, Jonathan Nieder
no flags Details
valgrind output (35.94 KB, text/plain)
2011-05-12 20:48 UTC, Jonathan Nieder
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Nieder 2011-05-12 20:46:03 UTC
Created attachment 46658 [details]
X server log exhibiting crash

Steve M. Robbins <steve@sumost.ca> noticed that uninstalling the ati driver on his system caused X to crash at startup.  It turned out to be a misconfiguration --- since the right driver to use (radeon) was not autodetected, X used the fbdev driver. The fbdev driver is not supposed to make Xorg crash, though, hence this report.

The good news:

> I can confirm that *without* xserver-xorg-video-ati installed:
>
> 1. If I comment out the virtual directive, there is no crash.
> 2. If I remove xorg.conf completely, there is no crash.
>
> There is still a bunch of diagnostics in the log file:
>
> [255110.061] (==) Depth 24 pixmap format is 32 bpp
> [255110.264] (==) FBDEV(0): Backing store disabled
> [255110.264] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
> [255110.264] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
> [255110.264] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
>
> Once I install xserver-xorg-video-ati, I can remove xorg.conf and it
> runs using the RADEON driver.

Original report is at http://bugs.debian.org/625521

Xorg.0.log attached.  Will attach more info in followup.
Comment 1 Jonathan Nieder 2011-05-12 20:46:48 UTC
Created attachment 46659 [details]
"fbset -i" output
Comment 2 Jonathan Nieder 2011-05-12 20:47:34 UTC
Created attachment 46660 [details]
xorg.conf that triggered it
Comment 3 Jonathan Nieder 2011-05-12 20:48:04 UTC
Created attachment 46661 [details]
full backtrace
Comment 4 Jonathan Nieder 2011-05-12 20:48:23 UTC
Created attachment 46662 [details]
valgrind output
Comment 5 GitLab Migration User 2018-08-10 20:41:35 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-fbdev/issues/2.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.