Bug 3728 - Crash with BCGHACKERSURVEY-0.73.pdf
Crash with BCGHACKERSURVEY-0.73.pdf
Status: RESOLVED FIXED
Product: poppler
Classification: Unclassified
Component: general
unspecified
x86 (IA32) Linux (All)
: high normal
Assigned To: Kristian Høgsberg
:
: 3570 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-08 20:54 UTC by Marco Pesenti Gritti
Modified: 2005-07-25 21:19 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Pesenti Gritti 2005-07-08 20:54:07 UTC
Splash backend

To reproduce open the document and scroll down some pages.

#4  0x05d645b6 in SplashXPathScanner::SplashXPathScanner ()
   from /usr/lib/libpoppler.so.0
No symbol table info available.
#5  0x05d5998c in Splash::fillWithPattern () from
/usr/lib/libpoppler.so.0
No symbol table info available.
#6  0x05d59b29 in Splash::fill () from /usr/lib/libpoppler.so.0
No symbol table info available.
#7  0x05cda9ff in SplashOutputDev::eoFill () from
/usr/lib/libpoppler.so.0
No symbol table info available.
#8  0x05cf384d in Gfx::opEOFill () from /usr/lib/libpoppler.so.0
No symbol table info available.
#9  0x05ceb85a in Gfx::execOp () from /usr/lib/libpoppler.so.0
No symbol table info available.
#10 0x05cebaf2 in Gfx::go () from /usr/lib/libpoppler.so.0
No symbol table info available.
#11 0x05cec54d in Gfx::display () from /usr/lib/libpoppler.so.0
No symbol table info available.
#12 0x05d28481 in Page::displaySlice () from /usr/lib/libpoppler.so.0
No symbol table info available.
#13 0x05801acd in poppler_page_render_to_pixbuf ()

Error (149087): Unknown operator 'o62'
Error (149087): Too few (1) args to 'l' operator
Error (149087): No current point in closepath
Error (149087): Unknown operator 'n156.0.q'
Error (149087): Unknown operator 'o62'
Error (149087): Unknown operator 'e'
Error (149087): Unknown operator 'e'
Error (149087): Unknown operator 'Q5'
Error (149087): Too few (1) args to 'l' operator
Error (149087): No current point in lineto
Error (149087): No current point in lineto
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): No current point in lineto
Error (149087): Too few (1) args to 'rg' operator
Error (149087): Unknown operator 'e'
Error (149087): No current point in closepath
Error (149087): No current point in closepath
Error (149087): Unknown operator 'o62'
Error (149087): Too few (1) args to 'l' operator
Error (149087): No current point in closepath
Error (149087): Unknown operator 'n15671'
Error (149087): Unknown operator 'o62'
Error (149087): Unknown operator 'e'
Error (149087): Unknown operator 'e'
Error (149087): Unknown operator 'Q5'
Error (149087): No current point in closepath
Error (149087): No current point in closepath
Error (149087): No current point in closepath
Error (149087): Too few (1) args to 'm' operator
Error (149087): No current point in closepath
Error (149087): No current point in closepath
Error (149087): No current point in closepath
Error (149087): No current point in closepath
Error (149087): Too few (1) args to 'rg' operator
Error (149087): No current point in lineto
Error (149087): Too few (2) args to 're' operator
Error (149087): No current point in closepath
Error (149087): No current point in closepath
Error (149087): Unknown operator 'o62'
Error (149087): Too few (1) args to 'l' operator
Error (149087): No current point in closepath
Error (149087): Unknown operator 'n15681.q'
Error (149087): Unknown operator 'o62'
Error (149087): Too few (1) args to 're' operator
Error (149087): Unknown operator 'Q156796'
Error (149087): Too few (0) args to 'l' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): No current point in closepath
Error (149087): Too few (1) args to 'rg' operator
Error (149087): Arg #0 to 'TD' operator is wrong type (name)
Error (149087): Unknown operator 'o62'
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'o62'
Error (149087): Unknown operator 'l250'
Error (149087): Too few (2) args to 'rg' operator
Error (149087): Unknown operator 'e'
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l250'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'l250'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'o62'
Error (149087): Too few (1) args to 'l' operator
Error (149087): No current point in closepath
Error (149087): Unknown operator 'n15690.q'
Error (149087): Unknown operator 'o62'
Error (149087): Unknown operator 'e'
Error (149087): Unknown operator 'Q15690.m'
Error (149087): Unknown operator 'm15690.m'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l250'
Error (149087): Too few (1) args to 'l' operator
Error (149087): Unknown operator 'm15690.m'
Error (149087): Unknown operator 'l250'
Error (149087): Too few (1) args to 'l' operator
Error (149087): Unknown operator 'm15690.m'
Error (149087): Unknown operator 'l25'
Error (149087): Unknown operator 'l25'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'm15690.m'
Error (149087): Unknown operator 'l25'
Error (149087): Unknown operator 'l25'
Error (149087): Unknown operator 'l250'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l25'
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'l' operator
Error (149087): Unknown operator 'm15690.m'
Error (149087): Unknown operator 'l250'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'm15690.m'
Error (149087): Unknown operator 'l25'
Error (149087): Unknown operator 'l25'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'm15690.m'
Error (149087): Unknown operator 'l25'
Error (149087): Unknown operator 'l25'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'l25'
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l25'
Error (149087): Unknown operator 'l25'
Error (149087): Too few (1) args to 'rg' operator
Error (149087): Unknown operator 'l25205.0.'
Error (149087): Unknown operator 'l252015'
Error (149087): Unknown operator 'l252015'
Error (149087): Unknown operator 'l250'
Error (149087): Too few (2) args to 'rg' operator
Error (149087): Too few (3) args to 're' operator
Error (149087): Unknown operator 'm15205.0.2581l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'm15205.0.2525'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'm15205.0.247.q'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'm15205.0.23662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'm15205.0.2311l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'm15205.0.2255'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'm15205.0.2195'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'm15205.0.1985'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'm15205.0.1925'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): No current point in closepath
Error (149087): Unknown operator 'm15205.0.'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'm15205.0.1715'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l2520662'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'l252066'
Error (149087): Too few (0) args to 'm' operator
Error (149087): Unknown operator 'o62'
Error (149087): Too few (1) args to 'l' operator
Error (149087): No current point in closepath
Error (149087): Unknown operator 'n152041'
Error (149087): Unknown operator 'o62'
Error (149087): Too few (1) args to 're' operator
Error (149087): Unknown operator 'Q152015'
Error (149087): Too many args in content stream
Error (149087): No current point in closepath
Error (149087): No current point in closepath
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'm152015'
Error (149087): Unknown operator 'l25202.q'
Error (149087): Unknown operator 'l25202.q'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'm152015'
Error (149087): Unknown operator 'l25202.q'
Error (149087): Unknown operator 'l25202.q'
Error (149087): Unknown operator 'l250'
Error (149087): No current point in closepath
Error (149087): Unknown operator 'l25202.q'
Error (149087): Unknown operator 'l25202.q'
Error (149087): No current point in closepath
Error (149087): No current point in closepath
Error (149087): Unknown operator 'm152015'
Error (149087): Unknown operator 'l25202.q'
Error (149087): Unknown operator 'l25202.q'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'm152015'
Error (149087): Unknown operator 'l25202.q'
Error (149087): Unknown operator 'l25202.q'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'l25202.q'
Error (149087): Unknown operator 'l25202.q'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'm152015'
Error (149087): Too few (1) args to 'm' operator
Error (149087): Too few (1) args to 'm' operator
Error (149087): Unknown operator 'm152015'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'm152015'
Error (149087): Unknown operator 'l25202.q'
Error (149087): Unknown operator 'l25202.q'
Error (149087): Unknown operator 'l250'
Error (149087): Unknown operator 'm152015'
Error (149087): Unknown operator 'l25202.q'
Error (149087): Unknown operator 'l25202.q'
Error (149087): Unknown operator 'l250'

evince bug:

http://bugzilla.gnome.org/show_bug.cgi?id=308005
Comment 1 Marco Pesenti Gritti 2005-07-08 20:54:39 UTC
Document url:
http://www.ostg.com/bcg/BCGHACKERSURVEY-0.73.pdf
Comment 2 Albert Astals Cid 2005-07-22 00:08:55 UTC
Created attachment 3119 [details]
PDF conversion of the magnified PostScript file

Page 21 content is fucked, but is too in Acroread 7 so it's more a pdf file
problem that a rendering problem
Comment 3 Kristian Høgsberg 2005-07-22 10:33:02 UTC
(In reply to comment #2)
> Created an attachment (id=3119) [edit]
> This patch fixes the bug
> 
> Page 21 content is fucked, but is too in Acroread 7 so it's more a pdf file
> problem that a rendering problem

It's strange that this can happen, since there's a check for an empty path
before creating the SplashXPath.  But apparently a sufficiently broken PDF can
do this.  As for the patch, this check should be equivalent:

  if (xPath->segs == NULL)

no?

Thanks for tracking this down, please commit.
Comment 4 Albert Astals Cid 2005-07-22 20:36:38 UTC
Fix will be in next poppler release. 
Comment 5 Albert Astals Cid 2005-07-27 07:19:28 UTC
*** Bug 3570 has been marked as a duplicate of this bug. ***