Bug 37497 - glib demo uses deprecated GTK+ functions
Summary: glib demo uses deprecated GTK+ functions
Status: RESOLVED FIXED
Alias: None
Product: poppler
Classification: Unclassified
Component: glib frontend (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
: 30998 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-23 05:22 UTC by İsmail Dönmez
Modified: 2012-05-19 03:14 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
avoid use of deprecated functions (8.80 KB, patch)
2011-10-20 02:10 UTC, David King
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description İsmail Dönmez 2011-05-23 05:22:00 UTC
Since GTK+ 2.24 the following functions used by glib demo is deprecated:

gtk_combo_box_append_text
gtk_combo_box_new_text
gtk_dialog_set_has_separator
gdk_draw_pixbuf

This causes implicit decleration problems.
Comment 1 David King 2011-10-20 02:10:58 UTC
Created attachment 52572 [details] [review]
avoid use of deprecated functions

This patch avoids the use of deprecated functions, instead using new API introduced in GTK+ 2.24. I tested the autotools changes and ran the demo, and it seems to work as before.
Comment 2 David King 2011-10-20 02:23:55 UTC
*** Bug 30998 has been marked as a duplicate of this bug. ***
Comment 3 Carlos Garcia Campos 2012-05-19 03:14:13 UTC
poppler-glib-demo has been ported to GTK3 and it doesn't use deprecated symbols anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.