Bug 3764 - Link REL next and previous
Link REL next and previous
Status: CLOSED WONTFIX
Product: openclipart.org
Classification: Unclassified
Component: dms
unspecified
x86 (IA32) All
: high enhancement
Assigned To: default user for a product
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-13 06:11 UTC by Daniel Stone
Modified: 2006-10-12 20:04 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FreeDesktop Bugzilla Database Corruption Fix User 2005-07-13 06:11:29 UTC
on the categories with mulitple pages, please try and inlcudes the LINK REL tags
for next and previous in the page header something like this 

<LINK REL="next" href="..." /> 
<LINK REL="prev" href="..." />

No one seems to be making much effort to implement this standard but it would be
really great if the OpenClipart DMS included it.  No hurry though, it isn't a
particulary important feature (although it is great to always have Next/Previous
in your own langauge thanks to the browser).
Comment 1 Jonadab the Unsightly One 2005-07-14 20:23:17 UTC
Are there any current browsers that actually support that?  I know mozilla did
for a few months during the 0.9.x timeframe, but I was under the impression that
it was dropped before 1.0, due to a general lack of any websites or other
browsers supporting it, and its consequent complete lack of usefulness.
Comment 2 FreeDesktop Bugzilla Database Corruption Fix User 2005-07-15 02:38:44 UTC
I'm pretty sure Opera supports it.  
Mozilla seamonkey has long supported this feature and continues to do so.  
Not sure about Konqueror/Safari

Firefox clearly doesn't seem to care about promoting standards (like this, like
MNG, only now are they finally getting their thumb out and trying to support SVG
again) but if more sites provided this funtionality they might put it back in. 
(If I could get Wordpress and a few others to implement this too it would be a
big help.  I even filed a request to add this to the HTML export of OpenOffice
many years ago but no joy there either and it look like I'll have to do it
myself if I ever want it done).  

I wouldn't make any claim about this being high priority but if it got done
anytime in the next year I'd be pleased.  
Comment 3 Jonathan Leighton 2005-07-15 16:39:45 UTC
Text browsers tend to support it I think, as it's somewhat of an accessibility aid.

"Firefox clearly doesn't seem to care about promoting standards"

I think that's a bit harsh. It's very easy for us to sit here and say...
Comment 4 FreeDesktop Bugzilla Database Corruption Fix User 2005-07-16 02:01:36 UTC
It was intended to be harsh.  I'd be less harsh if they cared more about
stability enough to keep the Adobe SVG plugin working but they didn't.  

I really dont like Firefox for a variety of reasons and it does a poor job of
innovating exactly the same things as what Opera has done.  They really threw
the baby out with the bathwater when they got rid of Mozilla and created Firefox
and alienated me as a  user in the process.  It was bundling more than producing
a "browser only" that got Microsoft ahead.
Maybe now they have bulked up their market share by pandering to Internet
Explorer users and making their browser inconsistent with itself across
platforms they will get their priorities back in order and make more of an
effort to create a better browser and promote standards instead of reinventing
the wheel (making the same damned mistakes as Netscape).  

I could bore you to tears with my litany of criticisms about Firefox but this
isn't really the place for it, and I'm not sure CC'ing the mailing list on every
bugzilla comment is such a great idea.  (It might be a good idea to retain the
mail to the list for every new bug opened and ignore additional messages after
that if possible.)
Comment 5 Jon Phillips 2006-09-21 11:13:39 UTC
Please refile with ccHost...