Bug 37659 - Gabble requests video to start when remote video is enabled partway through a call
Summary: Gabble requests video to start when remote video is enabled partway through a...
Status: NEW
Alias: None
Product: Telepathy
Classification: Unclassified
Component: gabble (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Telepathy bugs list
QA Contact: Telepathy bugs list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-27 02:07 UTC by vincent
Modified: 2011-05-27 02:10 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Gabble log (231.67 KB, text/x-log)
2011-05-27 02:07 UTC, vincent
Details
Relevant parts (from tp-*) of log from meego-app-im (8.64 KB, application/x-bzip)
2011-05-27 02:10 UTC, vincent
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vincent 2011-05-27 02:07:18 UTC
Tested with meego-app-im (a gabble using IM program) and empathy:

Start meego-app-im
Login to a jabber account using tp-gabble
Start an audio only call with another jabber account using gabble
Answer that call from the empathy side
After the call is established, enable video sending from empathy
meego-app-im gets a start-sending signal, and starts recording and sending video

I am not sure whether it's a gabble or other component (eg, tp-farsight) bug, but since this behavior does not happen when using another CM, gabble seems the likely culprit.

See attached tp-gabble log and relevant parts from meego-app-im log (note the last log of "Requesting that the application start sending" from tp-fs).
Comment 1 vincent 2011-05-27 02:07:57 UTC
Created attachment 47218 [details]
Gabble log
Comment 2 vincent 2011-05-27 02:10:28 UTC
Created attachment 47219 [details]
Relevant parts (from tp-*) of log from meego-app-im


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.