Bug 37986 - [GM45] Install of Ubuntu 11.04 backlight problem......
Summary: [GM45] Install of Ubuntu 11.04 backlight problem......
Status: CLOSED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Daniel Vetter
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-06 05:41 UTC by droopal
Modified: 2017-07-24 23:04 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
kern.log for not being able to load Ubuntu 11.04 (294.08 KB, text/plain)
2011-06-06 07:05 UTC, droopal
no flags Details
kern.log (672.11 KB, text/plain)
2011-06-06 10:40 UTC, droopal
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description droopal 2011-06-06 05:41:07 UTC
I have been trying to install Ubuntu 11.04 on an Acer Aspire 5736Z. I installs, and gets to reboot, where as soon as the log in page appears, the backlight turns off, at the same time as the drums sound. I have tried all sorts, since Natty came out. I have tried installing using the update manager, fresh install, fresh install using alternative cd, and now installing using .deb install found here http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0-rc1-oneiric/ all of which the same problem occurs, as it is booting, just as the log in page appears, the back light is turned off. I have added 'GRUB_GFXPAYLOAD_LINUX=TEXT' to /etc/default/grub/ updated grub rebooted still nothing. I am convinced it is a backlight problem, if it could found out why the backlight is turned off, then I could get it to work. I can actually blindly once the log on page is there, click on enter, add my password, and Natty seems to load, as I get the music. But its just a black screen. Hope somebody can help?
Comment 1 droopal 2011-06-06 07:05:48 UTC
Created attachment 47600 [details]
kern.log for not being able to load Ubuntu 11.04

Hi, I cannot work out where the fault is to edit the file, I have logged in to 3.0-rc1 logged out then into Maverick, and hopefully you can find at the end somewhere around timestamp 14.33 the information you need.
Comment 2 droopal 2011-06-06 10:40:46 UTC
Created attachment 47617 [details]
kern.log
Comment 3 Timo Aaltonen 2011-06-08 22:35:39 UTC
for the record; the latest logfile is with the acer_wmi module blacklisted, which was suggested to possibly interfere with the backlight functionality.
Comment 4 droopal 2012-04-23 03:04:35 UTC
On 23/04/2012 09:49, bugzilla-daemon@freedesktop.org wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=37986
>
> Timo Aaltonen<tjaalton@ubuntu.com>  changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>             Priority|high                        |medium
>
> Daniel Vetter<daniel@ffwll.ch>  changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Summary|Install of Ubuntu 11.04     |[GM45] Install of Ubuntu
>                     |backlight problem......     |11.04 backlight
>                     |                            |problem......
>
> --- Comment #3 from Timo Aaltonen<tjaalton@ubuntu.com>  2011-06-08 22:35:39 PDT ---
> for the record; the latest logfile is with the acer_wmi module blacklisted,
> which was suggested to possibly interfere with the backlight functionality.
>
I still cant get 11.04, 11.10 and 12.04 to work on the computer, have 
had to give up, as I dont have enough experience to do anymore with 
it......which is a pity because I bought that computer to work with 
Ubuntu.......I have had to reformat harddrive back to using just 
windows......
Comment 5 Chris Wilson 2012-05-11 07:17:51 UTC
Daniel is working on some patches to fix the backlight controller and is looking for victims^Wtesters.
Comment 6 Daniel Vetter 2012-06-05 07:09:33 UTC
Ok, I've created these patches, available at http://cgit.freedesktop.org/~danvet/drm/log/?h=backlight-confusion

Git link is git://people.freedesktop.org/~danvet/drm backlight-confusion

Please test them, thanks.
Comment 7 Jani Nikula 2012-08-28 09:41:37 UTC
(In reply to comment #6)
> Ok, I've created these patches, available at
> http://cgit.freedesktop.org/~danvet/drm/log/?h=backlight-confusion
> 
> Git link is git://people.freedesktop.org/~danvet/drm backlight-confusion
> 
> Please test them, thanks.

Updated patches and discussion at [1], also available in the "backlight" branch of [2]. Please test.

[1] http://thread.gmane.org/gmane.comp.freedesktop.xorg.drivers.intel/13642
[2] git://gitorious.org/jani/drm.git
Comment 8 Jani Nikula 2012-09-17 12:37:30 UTC
Please try i915.invert_brightness=1 module parameter with kernel version v3.5 or later, see if that fixes the brightness issue, and report 'lspci -vmmnn' if it does.
Comment 9 Jesse Barnes 2012-11-14 17:40:28 UTC
Looks like a potential dupe of #38718, have you been able to test as Jani suggested yet?
Comment 10 Jesse Barnes 2012-12-11 19:14:25 UTC
timed out, please reopen if this is still an issue with the latest bits


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.