Bug 38010 - DVI output not working with radeon on RV610
Summary: DVI output not working with radeon on RV610
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2011-06-06 14:10 UTC by darkbasic
Modified: 2012-02-01 14:44 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

dmesg (48.68 KB, text/plain)
2011-06-06 14:10 UTC, darkbasic
no flags Details
Xorg.0.log (40.98 KB, text/plain)
2011-06-06 14:13 UTC, darkbasic
no flags Details

Description darkbasic 2011-06-06 14:10:52 UTC
Created attachment 47622 [details]

Hi, I have an RV610 card attached to an LG 22LH2000. The LG 22LH2000 has a 1366x768 native resolution and does have VGA and HDMI but not DVI. The Radeon HD2400 does have VGA and DVI but not HDMI, so I'm using a DVI-HDMI converter.
When I use the VGA output everything works fine, but I don't get a 1:1 pixel mapping because I have to set a 1360x768 or 1368x768 resolution and the monitor is not smart enough when using vga. Instead when I attach the monitor to my laptop's Intel GMA45 HDMI output I can get a 1:1 pixel mapping even using a 1360x768 resolution.
Unfortunately when using the HD2400 DVI output the monitor does not show anything, at least after loading the radeon module. In fact when loading the bios or starting grub the DVI output works flawlessly. nomodeset does not help. I even tried setting another resolution with xrandr (it automatically set 1920x1080i, but I tried 1360x768, 1280x800, 1024x768 and 800x600 and it still does not work).

Distro is Debian Unstable amd64 with kernel 2.6.39 and xorg-edgers ppa.
It's the only monitor I will be able to use for a couple of months, it's critical for me to get it working.

Thank you
Comment 1 Alex Deucher 2011-06-06 14:13:06 UTC
Does booting with radeon.audio=0 on the kernel command line in grub help?
Comment 2 darkbasic 2011-06-06 14:13:48 UTC
Created attachment 47623 [details]
Comment 3 darkbasic 2011-06-06 14:18:41 UTC
> Does booting with radeon.audio=0 on the kernel command line in grub help?

OMG you had been faster than light, and it worked! Consider this card does not even have an HDMI output!

Thank you very much

Should I close this?
Comment 5 Rafał Miłecki 2012-01-30 00:22:39 UTC
darkbasic: I've request to you, could you try switching to some updated kernel and trying radeon.audio=1 option in GRUB?

In case of 3.0, please use 3.0.18 or newer.
In case of 3.1, please use 3.1.10 or newer.
In case of 3.2. please use 3.2.2 or newer.
Of course 3.3-rc1 is good as well.

The commit I want you to have is:

commit d21e9677f82d619967c6c918038343fe12bb0f4a
Author: Rafał Miłecki <zajec5@gmail.com>
Date:   Fri Dec 23 20:32:18 2011 +0100

    drm/radeon/kms: workaround invalid AVI infoframe checksum issue

Does you LG work fine with radeon after using radeon.audio=1?
Comment 6 darkbasic 2012-01-30 05:45:43 UTC
Sorry, I completely forgot about this bug! I will check this evening or tomorrow.
Comment 7 darkbasic 2012-02-01 14:44:30 UTC
It does work with radeon.audio=1 and 3.2.2 :)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.