Bug 38425 - please use UNCONFIRMED as default initial state for new bugs for LibreOffice
Summary: please use UNCONFIRMED as default initial state for new bugs for LibreOffice
Status: RESOLVED FIXED
Alias: None
Product: freedesktop.org
Classification: Unclassified
Component: Bugzilla (show other bugs)
Version: unspecified
Hardware: All All
: medium normal
Assignee: fd.o Admin Massive
QA Contact:
URL: https://wiki.mozilla.org/Bugzilla:FAQ...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-17 18:50 UTC by Christian Lohmaier
Modified: 2011-10-16 04:21 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Lohmaier 2011-06-17 18:50:27 UTC
While there is a status "UNCONFIRMED" - the default selection is NEW, thus people file bugs with the NEW state and that kind of defeats the purpose.

So please change the default selection to unconfirmed and have the user switch to NEW instead of the other way round.

AFAIK you only need to modify enter_bug.cgi

http://bzr.mozilla.org/bugzilla/3.6/annotate/head:/enter_bug.cgi#L546

Just remove the special handling of users with canconfirm/editbugs permission (as everyone has them)

i.e. remove the condition from the following

# If the user has no privs...
unless ($has_editbugs || $has_canconfirm) {
    # ... use UNCONFIRMED if available, else use the first status of the list.
    my $bug_status = (grep {$_ eq 'UNCONFIRMED'} @status) ? 'UNCONFIRMED' : $status[0];
    @status = ($bug_status);
}
Comment 1 Rainer Bielefeld Retired 2011-06-20 01:21:44 UTC
I do not have any Bugzilla administration experience, but I fond a.m. URL with a hint also for Bugzilla Versions < 3.6. Might be an alternative, if Christinan's suggestion can not be used because of unexpected difficulties?
Comment 2 Christian Lohmaier 2011-07-07 18:45:47 UTC
Hi sitewranglers - do you need any more info, or is it just a "busy with other things, will look into it later" problem?

Anything we could do to help?
Comment 3 Tollef Fog Heen 2011-07-08 13:04:30 UTC
This will be fixed once we get around to upgrading to 4.0
Comment 4 Tollef Fog Heen 2011-10-16 04:21:27 UTC
We've upgraded to 4.0 and this is now the default for libreoffice.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.