Bug 38428 - [IvyBridge]Video screen blank when playing video on firefox
[IvyBridge]Video screen blank when playing video on firefox
Status: VERIFIED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/Intel
unspecified
All Linux (All)
: high major
Assigned To: Kenneth Graunke
zhao jian
: NEEDINFO
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-17 22:06 UTC by meng
Modified: 2011-09-22 19:32 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (106.13 KB, text/plain)
2011-06-17 22:08 UTC, meng
no flags Details
The photo for video screen blank (254.47 KB, image/jpeg)
2011-06-17 22:10 UTC, meng
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description meng 2011-06-17 22:06:56 UTC
System Environment:
--------------------------
Platform: IvyBridge 
Libdrm:   (master)2.4.26
Mesa:    (master)8875dd58719b978283e89acf04422a4eaf9b021d
Xserver:  
(server-1.10-branch)xorg-server-1.10.2-11-g9551f5041915fa00ca243a279efb55de2ff11a00
Xf86_video_intel:(master)2.15.0-96-ga1ee4b930846d4ba9274028c08800b882fc926f1
Cairo:     (master)3b9c8744898823a4b09917f0540a324318fef726
Libva:     (master)3c1b6875b589f3a40709a889da85b979e34db625
Kernel:    (drm-intel-fixes)6a574b5b9b186e28abd3e571dfd1700c5220b510

Bug detailed description:
-------------------------
On gnome-session with compiz,video screen blank when playing video on firefox.
when cat i915_error_state,no error state collected.Pls see photo and Xrog.log.
It hard to reproduce.Full screen switch or VT switch could reproduce this problem.

But in console:
(npviewer.bin:3349): Gdk-WARNING **: XID collision, trouble ahead
** (deja-dup-monitor:2803): DEBUG: monitor.vala:263: Invalid next run date.  Not scheduling a backup.
*** NSPlugin Wrapper *** ERROR: NPClass::Invalidate() wait for reply: Connection reset by peer
*** NSPlugin Wrapper *** WARNING:(../src/npw-wrapper.c:2344):invoke_NPP_WriteReady: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(../src/npw-wrapper.c:2394):invoke_NPP_Write: assertion failed: (rpc_method_invoke_possible(plugin->connection))

Reproduce steps:
-------------------------
1.xinit&
2.gnome-session
3.play the video by firefox
4.full screen switch(full-->not full-->full) or VT switch many times
Comment 1 meng 2011-06-17 22:08:55 UTC
Created attachment 48123 [details]
Xorg.0.log
Comment 2 meng 2011-06-17 22:10:16 UTC
Created attachment 48124 [details]
The photo for video screen blank
Comment 3 meng 2011-06-19 22:30:21 UTC
The problem is tested with the commit 6a574b5b9b with follow patches.

Jesse's kernel patches in this thread : 
http://lists.freedesktop.org/archives/intel-gfx/2011-June/011014.html
Comment 4 Kenneth Graunke 2011-07-18 17:39:54 UTC
I'll try to reproduce this soon.  It honestly just looks like Flash crashed for some reason, though...
Comment 5 Gwenole Beauchesne 2011-07-19 05:22:13 UTC
Yes, I concur, this could be a Flash problem. However, more information would be needed. e.g. is this an x86_64 system? What's the version of gtk, nspluginwrapper and Flash Player?

Flash used to having focus and XEMBED problems in the past. This was a combination of Flash, Gtk, Firefox and nspluginwrapper bugs. It could be worth trying to reproduce either (i) without nspluginwrapper on a 32-bit platform, or (ii) with nspluginwrapper on a 32-bit platform. If this can be reproduced in both (i) and (ii) cases, then the most likely cause is Flash, and configuration (i) could make it easier to debug. e.g. attach the npviewer.bin process to gdb.
Comment 6 Eugeni Dodonov 2011-09-21 05:10:08 UTC
@Meng - does it still happens with 2011 Q3 version?

If it does, could you please try to isolate the problem as Gwenole suggested?

Thanks!
Comment 7 Gordon Jin 2011-09-21 18:17:01 UTC
Meng has left our team. Jian, can you follow up?

I think this should exist in Q3 release. Let's try the latest code first.
Comment 8 cc 2011-09-22 02:29:27 UTC
On our IvyBridge(ivb2) with the newest unstable kernel(unstable_20110921+) and X package ,the video can be played well by firefox.
Comment 9 cc 2011-09-22 19:32:12 UTC
the video can be played well by firefox