Bug 38602 - [bisected] Wrong display after "prefer native texture formats when possible" commit
[bisected] Wrong display after "prefer native texture formats when possible" ...
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Mesa core
git
Other All
: medium major
Assigned To: mesa-dev
:
: 38610 38611 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-23 05:02 UTC by Jure Repinc
Modified: 2011-06-23 15:08 UTC (History)
2 users (show)

See Also:


Attachments
kde-ok,png (864.67 KB, image/png)
2011-06-23 05:03 UTC, Jure Repinc
Details
kde-bad.png (34.64 KB, image/png)
2011-06-23 05:04 UTC, Jure Repinc
Details
Xorg.0.log (34.68 KB, text/plain)
2011-06-23 05:16 UTC, Jure Repinc
Details
dmesg (245.52 KB, text/plain)
2011-06-23 05:18 UTC, Jure Repinc
Details
try to undo the damage (1.85 KB, patch)
2011-06-23 06:38 UTC, Brian Paul
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jure Repinc 2011-06-23 05:02:36 UTC
After I updated my mesa and restarted X the KDE Plasma desktop and apps were displayed wrongly. Some parts were just black and what was visible was all reddish. I bisected the commits and the first one causing problems is:

1a339b6c71ebab6e1a64f05b2e133022d3bbcd15
st/mesa: prefer native texture formats when possible.

If I disabled KDE Kwin desktop effects the display was OK.

I'm using KDE software version 4.6.4, Linux kernel 3.0.0-rc1, libbdrm and xf86-video-ati are from git.
Comment 1 Jure Repinc 2011-06-23 05:03:42 UTC
Created attachment 48330 [details]
kde-ok,png
Comment 2 Jure Repinc 2011-06-23 05:04:25 UTC
Created attachment 48331 [details]
kde-bad.png
Comment 3 Jure Repinc 2011-06-23 05:05:55 UTC
I forgot to mention: the graphics card used is ATI Mobility Radeon HD 5470
Comment 4 Jure Repinc 2011-06-23 05:16:23 UTC
Created attachment 48332 [details]
Xorg.0.log
Comment 5 Jure Repinc 2011-06-23 05:18:03 UTC
Created attachment 48333 [details]
dmesg
Comment 6 Brian Paul 2011-06-23 06:38:21 UTC
Created attachment 48334 [details] [review]
try to undo the damage

Can you try this patch?  It disables choosing the Gallium formats that have no counterpart in Mesa.
Comment 7 Brian Paul 2011-06-23 07:18:13 UTC
BTW, I've added a new piglit test that catches the regression from the commit in question: texture-packed-formats
Comment 8 Brian Paterni 2011-06-23 08:13:44 UTC
(In reply to comment #6)
> Created an attachment (id=48334) [details]
> try to undo the damage
> 
> Can you try this patch?  It disables choosing the Gallium formats that have no
> counterpart in Mesa.

I've found that this patch also fixes a crash during Steam login. :)
Comment 9 Sven Arvidsson 2011-06-23 10:26:06 UTC
*** Bug 38610 has been marked as a duplicate of this bug. ***
Comment 10 Sven Arvidsson 2011-06-23 10:29:24 UTC
FWIW, the same commit causes the game ETQW to segfault on start, and log these
errors:

EE eg_state_inlines.h:388 r600_translate_colorswap - unsupported colorswap
format 67
[...]
Mesa 7.11-devel implementation error: _mesa_texstore_null() is called
[...]
FATAL ERROR: Image '_quadratic' was generated with internal format 0x8051 but
GL returned 0x1

The patch fixes the segfault, but doesn't make the game render correctly.
Comment 11 Sven Arvidsson 2011-06-23 12:49:29 UTC
fa5478c5fe88e9c07d30203984b712925de84d2e with the patch takes care of the problems with ETQW.
Comment 12 Brian Paul 2011-06-23 15:07:31 UTC
Fixed w/ commit 1f544cc58794cffe5d5cac5a83efde91154f1b7d
Comment 13 Brian Paul 2011-06-23 15:08:22 UTC
*** Bug 38611 has been marked as a duplicate of this bug. ***