Bug 38847 - Applications segfault on specific cursor configuration
Summary: Applications segfault on specific cursor configuration
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Lib/Xcursor (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard: 2011BRB_Reviewed
Keywords: want-backtrace
Depends on:
Blocks:
 
Reported: 2011-06-30 09:51 UTC by Vavooon
Modified: 2018-08-10 20:17 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
cursor theme for reproducing a bug (696.92 KB, application/x-gzip)
2011-06-30 09:52 UTC, Vavooon
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vavooon 2011-06-30 09:51:41 UTC
Description: When i tried to change cursor in Gnome 3 (in manual way, because there is no any other) some applications, such as Pidgin, Firefox, Gnome-Commander and some others fell with SEGMENTATION FAULT error. 
Reproducing: to reproduce this bug you need to copy 'default' and 'Pulse-Glass' directories from archive into /usr/share/icons and change the cursor theme with Gnome-Tweak tool.
Comment 1 Vavooon 2011-06-30 09:52:40 UTC
Created attachment 48601 [details]
cursor theme for reproducing a bug
Comment 2 Jeremy Huddleston Sequoia 2011-10-06 11:17:43 UTC
Can you please attach the backtrace of the crash you are seeing?
Comment 3 Vavooon 2011-10-06 22:11:51 UTC
Sorry, but i do not use Gnome 3 (and Linux) actually.
Comment 4 cfr 2014-06-07 21:26:19 UTC
Possibly related: https://bugs.freedesktop.org/show_bug.cgi?id=3603 ?
Comment 5 GitLab Migration User 2018-08-10 20:17:10 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/lib/libxcursor/issues/1.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.