Bug 38859 - Clipping in some fonts after returning from sleep
Summary: Clipping in some fonts after returning from sleep
Status: NEW
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/R100 (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-30 19:25 UTC by chris
Modified: 2011-07-06 07:12 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Image with annotations of the issue (246.38 KB, image/png)
2011-06-30 19:27 UTC, chris
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chris 2011-06-30 19:25:29 UTC
Using Gnome 3, Arch Linux (current), with these opensource drivers(latest from Arch Linux repos) I have issues when recovering from sleep sometimes. The screen will begin to display some fonts with several fonts clipped which can only be solved with a restart. For instance E's are cut off in half.

The attached image shows various examples of this annotated and highlighted to show the issue.
Comment 1 chris 2011-06-30 19:27:01 UTC
Created attachment 48631 [details]
Image with annotations of the issue
Comment 2 Alex Deucher 2011-06-30 19:38:00 UTC
What chip are you using?  Please attach your xorg log and dmesg output.  Also when you say sleep, do you mean suspend or dpms?
Comment 3 chris 2011-07-03 12:15:16 UTC
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M66GL [ATI
Mobility FireGL V5250] [1002:71d4] (prog-if 00 [VGA controller])
    Subsystem: Lenovo Device [17aa:20a4]
    Flags: bus master, fast devsel, latency 0, IRQ 48
    Memory at d0000000 (32-bit, prefetchable) [size=256M]
    I/O ports at 2000 [size=256]
    Memory at ee100000 (32-bit, non-prefetchable) [size=64K]
    [virtual] Expansion ROM at ee120000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: radeon
    Kernel modules: radeon

And by sleep I just mean that I am using Gnome3 and either shutting the lid or clicking suspend in the corner. I'm not sure if what it says it's doing is what you mean though.
Comment 4 Alex Deucher 2011-07-05 07:12:58 UTC
Does running an app the uses Xv fix the issue?
Comment 5 chris 2011-07-05 07:14:05 UTC
(In reply to comment #4)
> Does running an app the uses Xv fix the issue?

I'm not sure what that is?
Comment 6 Alex Deucher 2011-07-05 07:16:17 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Does running an app the uses Xv fix the issue?
> 
> I'm not sure what that is?

Xv = Xvideo extension.  Try playing a video in totem (gnome movie player).
Comment 7 chris 2011-07-06 06:23:08 UTC
I needed the problem to reoccur to test this and it did. I tried to play videos with Totem and it couldn't play video but then I tried Mplayer and it fixed some of the fonts but not all of them. I'm not sure if its not just because they weren't reloaded but its a little better.
Comment 8 Alex Deucher 2011-07-06 06:31:37 UTC
Sounds like some missing state init in the 3D driver.
Comment 9 chris 2011-07-06 07:11:13 UTC
Like an issue in the code or the config?
Comment 10 Alex Deucher 2011-07-06 07:12:12 UTC
(In reply to comment #9)
> Like an issue in the code or the config?

3D driver code.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.