Bug 39083 - [regression, bisected, r600g] Wrong rendering of Bubbles3D screensaver
Summary: [regression, bisected, r600g] Wrong rendering of Bubbles3D screensaver
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-08 23:45 UTC by Jure Repinc
Modified: 2011-07-10 10:33 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
bubble3d-good.png (31.92 KB, image/png)
2011-07-08 23:46 UTC, Jure Repinc
Details
bubble3d-bad.png (35.49 KB, image/png)
2011-07-08 23:46 UTC, Jure Repinc
Details
[PATCH] r600g: LIT: clamp negative src.y to 0 (2.22 KB, patch)
2011-07-09 02:55 UTC, Vadim Girlin
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jure Repinc 2011-07-08 23:45:41 UTC
Instead of looking smooth and nicely translucent some part of bubbles appear to be opaque. I've bisected and the commit that caused this bad rendering is:

86f8b4117f35c788c8a043c2e241eb19eaacae8c
- r600g: LIT: swap MUL_LIT operands to fix 0^0

This is on AMD Radeon HD 5750 and with XScreenSaver 5.14
Comment 1 Jure Repinc 2011-07-08 23:46:20 UTC
Created attachment 48911 [details]
bubble3d-good.png
Comment 2 Jure Repinc 2011-07-08 23:46:49 UTC
Created attachment 48912 [details]
bubble3d-bad.png
Comment 3 Vadim Girlin 2011-07-09 02:55:17 UTC
Created attachment 48913 [details] [review]
[PATCH] r600g: LIT: clamp negative src.y to 0

Does this patch help?
Comment 4 Jure Repinc 2011-07-09 08:10:44 UTC
Yes, with the patch applied the problem is gone. Thank you very much.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.