Bug 39158 - [bisected]piglit glx/glx-swap-event_async failed
Summary: [bisected]piglit glx/glx-swap-event_async failed
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: GLX (show other bugs)
Version: git
Hardware: All Linux (All)
: high normal
Assignee: Jesse Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-12 00:04 UTC by fangxun
Modified: 2011-07-14 03:58 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fangxun 2011-07-12 00:04:56 UTC
System Environment:
--------------------------
Arch:        i386
Platform:    huronriver 
Libdrm:   (master)2.4.26
Mesa:     (master)12265d26ddc72f62de927ac24e12ab41fcd8d1c5
Xserver: (master)xorg-server-1.10.3-2-gafb537d56af9a037c4f43d90795fb7e9acb7f9d2
Xf86_video_intel:(master)2.15.0-189-g9f22ea7ca440c788f8104647356393c96c62d155
Kernel_unstable:(drm-intel-next)c7c369472dad852f6fe06a8be94dea72de784934


Bug detailed description:
-------------------------
Piglit glx-swap-event_async and glx-swap-event_event regressed on pineview, ironlake and sandybridge. 
Output of the case shows: 
Error: swap event returned 0 swap count
PIGLIT: {'result': 'fail' }

Bisect find commit 1e39fc784bc3d0d5ad01d9c14 is the first bad commit.
commit 1e39fc784bc3d0d5ad01d9c147529ac0e10f1262
Author:     Jesse Barnes <jbarnes@virtuousgeek.org>
AuthorDate: Thu May 5 13:09:16 2011 -0700
Commit:     Jesse Barnes <jbarnes@virtuousgeek.org>
CommitDate: Fri Jul 8 12:31:13 2011 -0700

    DRI2/GLX: use new swap event types

    Use the new swap event type so we get valid SBC values.

    Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>
    Reviewed-by: Jeremy Huddleston <jeremyhu@apple.com>
    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>


Reproduce steps:
----------------
1. xinit&
2. ./glx-swap-event -auto --async
Comment 1 Ian Romanick 2011-07-12 08:20:36 UTC
This is not a bug in the i965 driver.  The commit affects the generic GLX code, and the bug affects i915 hardware as well.

Was this Mesa update tested with the corresponding xserver update?  Perhaps the swap event extension should be disabled when there's a Mesa / xserver version mismatch.
Comment 2 Ian Romanick 2011-07-12 09:53:02 UTC
I *hate* the "reset assignee to default" box.
Comment 3 fangxun 2011-07-14 03:52:30 UTC
Thanks Ian,  the root cause is Mesa / xserver version mismatch.
Comment 4 fangxun 2011-07-14 03:58:10 UTC
Verified with Mesa: (master)02c8ee202f5a159659a027deae4721ff05cd1530
and Xserver: (master)xorg-server-1.10.99.901-104-g01dbf2514aa0cc8c40a876a24e3cb0737c41da19.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.