Bug 3934 - reject screenshot submissions
reject screenshot submissions
Status: CLOSED FIXED
Product: openclipart.org
Classification: Unclassified
Component: website
unspecified
x86 (IA32) All
: high normal
Assigned To: default user for a product
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-31 22:36 UTC by Daniel Stone
Modified: 2006-10-12 20:04 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FreeDesktop Bugzilla Database Corruption Fix User 2005-07-31 22:36:44 UTC
need a way to mark screenshot submissions as rejected (mentioned this on the
list and shortly after someone submitted inappropriate sexual content).  

the current system could be abused to host innappropriate images, we need a way
to flag those images as innappropriate and then later delete them.  

As I'm filing a bug report I'm thinking perhaps we could use bugzilla for people
to attach submissions, but I'm not sure bugzilla provides a convenient way to
delete attachments either.
Comment 1 Nicu Buculei 2005-08-01 15:46:14 UTC
a description on how to delete submited screenshots is here:
http://lists.freedesktop.org/archives/clipart/2005-March/002418.html

in short:
Visit the following URI:
http://openclipart.org/cgi-bin/upload_screenshot.cgi?reject=NNN
(Where NNN is the number of the screenshot, e.g., reject=101 will
reject screenshot number 101.)

the files we talked about on the list recently were not in the scrrenshots
section  but just in the incoming directory for clipart. to delete from there,
you need a kind of access to the f.d.o server to modify a script
(http://openclipart.org/tools/rm_incoming.php) and then run it in browser, see
http://lists.freedesktop.org/archives/clipart/2005-July/003662.html
Comment 2 Jonadab the Unsightly One 2005-08-24 19:42:42 UTC
Oh, incidentally, I found another way this issue manifests itself.  If a
zipfile or tarball is uploaded, and the metadata experience this issue,
propagate-metadata.pl cannot propagate them, because XML::Twig cannot
parse metadata.rdf, due to the invalid character.  Here is an example of
such a file:
http://www.openclipart.org/incoming-pre-0.17/chemical_accessories_mar_02.zip
Comment 3 Jonadab the Unsightly One 2005-08-25 02:53:04 UTC
Ignore previous comment; it was intended for another bug.
Comment 4 ryanlerch 2006-09-06 20:56:12 UTC
obsolete due to the implementation of screenshots in cchost...