Bug 39572 - Cogs: GPU hang
Cogs: GPU hang
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600
git
Other All
: medium normal
Assigned To: Default DRI bug account
http://www.humblebundle.com/
:
: 39617 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-26 13:58 UTC by Sven Arvidsson
Modified: 2012-08-07 01:49 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg output (60.76 KB, text/plain)
2011-07-26 13:58 UTC, Sven Arvidsson
Details
[PATCH] r600g: fix vs export count (1.56 KB, patch)
2011-07-28 07:13 UTC, Vadim Girlin
Details | Splinter Review
[PATCH] gallium: vertex buffer optimization (6.50 KB, patch)
2011-07-29 03:04 UTC, Vadim Girlin
Details | Splinter Review
r300g support for previous patch (not tested) (601 bytes, patch)
2011-07-29 21:16 UTC, Vadim Girlin
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Arvidsson 2011-07-26 13:58:07 UTC
Created attachment 49589 [details]
dmesg output

The game Cogs (from the Humble Indie Bundle) is causing a GPU hang. Unless the process is killed quickly the reset functionality doesn't seem to work so a full reboot is necessary.

The hang only happens if shadows is turned on in the game options, which it is by default so the hang happens right after launching the game.

No difference between 7.11 and git master.

Something else seems to be wrong with the game as it's pegging the CPU at 100% and performance is just a few frames per second.

System environment:
-- system architecture: 32-bit
-- Linux distribution: Debian unstable
-- GPU: REDWOOD
-- Model: XFX Radeon HD 5670 1GB
-- Display connector: DVI
-- xf86-video-ati: 6.14.2
-- xserver: 1.10.2.902
-- mesa: 860c51d82711936d343b55aafb46befc8c032fe6
-- drm: 2.4.26
-- kernel: 3.0
Comment 1 Alex Deucher 2011-07-28 06:42:37 UTC
*** Bug 39617 has been marked as a duplicate of this bug. ***
Comment 2 Vadim Girlin 2011-07-28 07:13:43 UTC
Created attachment 49666 [details] [review]
[PATCH] r600g: fix vs export count

Does this patch help?
Comment 3 Sven Arvidsson 2011-07-28 13:12:37 UTC
(In reply to comment #2)
> Created an attachment (id=49666) [details]
> [PATCH] r600g: fix vs export count
> 
> Does this patch help?

It does! Thank you :)

The game is still really slow, but I'll open another bug about that, possibly first see if it's only on r600g or something common to all Mesa/G3D drivers.
Comment 4 Alex Deucher 2011-07-28 16:57:29 UTC
Pushed:
95ee961f77119826382cfbc617334aed986b72e5

Thanks!
Comment 5 Vadim Girlin 2011-07-29 03:04:49 UTC
Created attachment 49707 [details] [review]
[PATCH] gallium: vertex buffer optimization

This experimental patch should help with performance in cogs, though it needs more work and testing. I'm not sure if it's the right way to implement such optimization at all.
Comment 6 Sven Arvidsson 2011-07-29 05:23:56 UTC
(In reply to comment #5)
> This experimental patch should help with performance in cogs, though it needs
> more work and testing. I'm not sure if it's the right way to implement such
> optimization at all.

It seems to work fine here. There's a night-and-day difference with and without this patch!
Comment 7 Pavel Ondračka 2011-07-29 07:14:03 UTC
Just wondering, will this optimization be possible for r300g too?
Comment 8 Vadim Girlin 2011-07-29 21:16:52 UTC
Created attachment 49735 [details] [review]
r300g support for previous patch (not tested)

(In reply to comment #7)
> Just wondering, will this optimization be possible for r300g too?

I think it should be rewritten in more generic way, so that the specific drivers won't need to care about it. I'll look into it. 

But if you want to test this in its current state, then you could try attached patch for r300g, it needs to be applied after the previous patch. I can't test without r300 hw though, so I'm not sure it'll work.
Comment 9 Pavel Ondračka 2011-07-30 00:14:38 UTC
(In reply to comment #8)
> Created an attachment (id=49735) [details]
> r300g support for previous patch (not tested)
> 
> (In reply to comment #7)
> > Just wondering, will this optimization be possible for r300g too?
> 
> I think it should be rewritten in more generic way, so that the specific
> drivers won't need to care about it. I'll look into it. 
> 
> But if you want to test this in its current state, then you could try attached
> patch for r300g, it needs to be applied after the previous patch. I can't test
> without r300 hw though, so I'm not sure it'll work.

It works fine with my RV530 card.