Bug 39766 - mission-control-5 crashed with SIGSEGV in g_str_hash()
Summary: mission-control-5 crashed with SIGSEGV in g_str_hash()
Status: RESOLVED DUPLICATE of bug 40283
Alias: None
Product: Telepathy
Classification: Unclassified
Component: mission-control (show other bugs)
Version: unspecified
Hardware: Other All
: medium critical
Assignee: Telepathy bugs list
QA Contact: Telepathy bugs list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-02 08:19 UTC by Pedro Villavicencio
Modified: 2011-08-22 04:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro Villavicencio 2011-08-02 08:19:39 UTC
this report has been filed here:

https://bugs.launchpad.net/ubuntu/+source/telepathy-mission-control-5/+bug/814511

mission control crashed after trying to open a chat window, backtrace:

.
Thread 1 (Thread 4348):
#0  g_str_hash (v=0x0) at /build/buildd/glib2.0-2.29.10/./glib/gstring.c:142
        p = 0x0
        h = 5381
#1  0x00007f49366aa713 in g_hash_table_lookup_node (hash_table=0xea9800, key=0x0) at /build/buildd/glib2.0-2.29.10/./glib/ghash.c:360
        node_hash = <value optimized out>
        hash_value = <value optimized out>
        have_tombstone = 0
        step = 0
        node_index = <value optimized out>
        first_tombstone = 0
#2  g_hash_table_lookup (hash_table=0xea9800, key=0x0) at /build/buildd/glib2.0-2.29.10/./glib/ghash.c:1022
        node_hash = <value optimized out>
        __PRETTY_FUNCTION__ = "g_hash_table_lookup"
#3  0x0000000000426682 in mcd_dispatcher_client_needs_recovery_cb (client=0xef4460, self=0xeb1000) at mcd-dispatcher.c:683
        handler = <value optimized out>
        channel = 0xebdc70
        object_path = 0xf510d0 "/org/freedesktop/Telepathy/Connection/gabble/jabber/alex_2ehunziker_40gmail_2ecom_2f860f19f0/ImChannel3"
        properties = <value optimized out>
        hname = 0x0
        channels = <value optimized out>
        observer_filters = 0xf6baa0
        list = 0xf04c80
        __PRETTY_FUNCTION__ = "mcd_dispatcher_client_needs_recovery_cb"
#4  0x00007f4936b96e84 in g_closure_invoke (closure=0xf2d080, return_value=0x0, n_param_values=1, param_values=0xf04ae0, invocation_hint=<value optimized out>) at /build/buildd/glib2.0-2.29.10/./gobject/gclosure.c:773
        marshal = 0x7f4936b981c0 <g_cclosure_marshal_VOID__VOID>
        marshal_data = <value optimized out>
        in_marshal = <value optimized out>
        __PRETTY_FUNCTION__ = "g_closure_invoke"
#5  0x00007f4936baa0fb in signal_emit_unlocked_R (node=<value optimized out>, detail=0, instance=0xef4460, emission_return=0x0, instance_and_params=0xf04ae0) at /build/buildd/glib2.0-2.29.10/./gobject/gsignal.c:3256
        tmp = <value optimized out>
        handler = 0xf7c130
        accumulator = 0x0
        emission = {next = 0x0, instance = 0xef4460, ihint = {signal_id = 45, detail = 0, run_type = G_SIGNAL_RUN_FIRST}, state = EMISSION_RUN, chain_type = 4}
        class_closure = 0x0
        hlist = 0x7f4936de4d70
        handler_list = 0xf7c130
        return_accu = 0x0
        accu = {g_type = 0, data = {{v_int = 0, v_uint = 0, v_long = 0, v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, v_pointer = 0x0}, {v_int = 0, v_uint = 0, v_long = 0, v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, v_pointer = 0x0}}}
        signal_id = 45
        max_sequential_handler_number = 2436
        return_value_altered = 0
#6  0x00007f4936bb3707 in g_signal_emit_valist (instance=<value optimized out>, signal_id=<value optimized out>, detail=<value optimized out>, var_args=0x7fff3219e238) at /build/buildd/glib2.0-2.29.10/./gobject/gsignal.c:2987
        instance_and_params = 0xf04ae0
        signal_return_type = 4
        param_values = 0xf04af8
        node = 0xecf220
        i = <value optimized out>
        n_params = 0
        __PRETTY_FUNCTION__ = "g_signal_emit_valist"
#7  0x00007f4936bb38d2 in g_signal_emit (instance=<value optimized out>, signal_id=<value optimized out>, detail=<value optimized out>) at /build/buildd/glib2.0-2.29.10/./gobject/gsignal.c:3044
        var_args = {{gp_offset = 24, fp_offset = 48, overflow_arg_area = 0x7fff3219e310, reg_save_area = 0x7fff3219e250}}
#8  0x00007f493755ead8 in _tp_cli_dbus_properties_invoke_callback_get_all (self=0xef4460, error=0x0, args=0xee9e80, generic_callback=0x43bf60 <_mcd_client_proxy_observer_get_all_cb>, user_data=<value optimized out>, weak_object=<value optimized out>) at _gen/tp-cli-generic-body.h:1190
        callback = 0x43bf60 <_mcd_client_proxy_observer_get_all_cb>
#9  0x00007f4937565840 in tp_proxy_pending_call_idle_invoke (p=0xf7e240) at proxy-methods.c:153
        pc = 0xf7e240
        invoke = <value optimized out>
        __PRETTY_FUNCTION__ = "tp_proxy_pending_call_idle_invoke"
#10 0x00007f49366bbcbd in g_main_dispatch (context=0xe90790) at /build/buildd/glib2.0-2.29.10/./glib/gmain.c:2473
        dispatch = 0x7f49366b79a0 <g_idle_dispatch>
        was_in_call = 0
        user_data = 0xf7e240
        callback = 0x7f49375657d0 <tp_proxy_pending_call_idle_invoke>
        cb_funcs = 0x7f4936965650
        cb_data = 0xf86330
        current_source_link = {data = 0xf86b20, next = 0x0}
        need_destroy = <value optimized out>
        source = 0xf86b20
        current = 0xec4950
        i = <value optimized out>
#11 g_main_context_dispatch (context=0xe90790) at /build/buildd/glib2.0-2.29.10/./glib/gmain.c:3046
No locals.
#12 0x00007f49366bc4b8 in g_main_context_iterate (context=0xe90790, block=<value optimized out>, dispatch=1, self=<value optimized out>) at /build/buildd/glib2.0-2.29.10/./glib/gmain.c:3124
        max_priority = -100
        timeout = 0
        some_ready = 1
        nfds = 0
        allocated_nfds = <value optimized out>
        fds = <value optimized out>
#13 0x00007f49366bc9f2 in g_main_loop_run (loop=0xe8dfd0) at /build/buildd/glib2.0-2.29.10/./glib/gmain.c:3332
        __PRETTY_FUNCTION__ = "g_main_loop_run"
#14 0x000000000040e9a5 in main (argc=<value optimized out>, argv=<value optimized out>) at mc-server.c:78
        mcd = 0xe96010
Comment 1 Xavier Claessens 2011-08-22 04:41:26 UTC
Sorry did not see this launchpad bug got reported upstream already. I've opened bug #40283 with more detailed reason and attached patch. Let's fix this one as dup then.

*** This bug has been marked as a duplicate of bug 40283 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.