Bug 39848 - sensors are inaccessible on radeon X1950 PCIe
Summary: sensors are inaccessible on radeon X1950 PCIe
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-04 23:47 UTC by Thierry Vignaud
Modified: 2011-08-04 23:55 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
kernel-3.0 dmesg (39.59 KB, text/plain)
2011-08-04 23:48 UTC, Thierry Vignaud
no flags Details
ROM (61.50 KB, application/octet-stream)
2011-08-04 23:50 UTC, Thierry Vignaud
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thierry Vignaud 2011-08-04 23:47:40 UTC
My X1950 (RV350) Radeon card has a hw monitoring chip onboard.
I read that it's now possible to access it via the dri framework and the standard lm-sensors toolkit, and the lm63 is the driver I need.

I ran sensors-detect:

Next adapter: Radeon i2c bit bus 0x92 (i2c-2)
Do you want to scan it? (YES/no/selectively):
Client found at address 0x4c
(...)
Probing for `National Semiconductor LM63'...                Success!
    (confidence 6, driver `lm63')
(...)
Now follows a summary of the probes I have just done.
(...)
Driver `lm63':
  * Bus `Radeon i2c bit bus 0x92'
    Busdriver `UNKNOWN', I2C address 0x4c
    Chip `National Semiconductor LM63' (confidence: 6)

But lm63 doesn't seem to work. Modules load without any error, but if I run 'sensors', only the motherboard sensors are printed.
qFrom dmesg:
i2c /dev entries driver
smsc47b397: found SMSC LPC47B397-NC (base address 0x0900, revision 1)


With kernel 2.6.3x and 3.0
With xserver 1.7, 1.9 & 1.10
with x11 driver 6.14.1 & previous too

$ lspcidrake -v|fgrep VGA
lCard:ATI Radeon X1950 and earlier: ATI Technologies Inc|RV530LE [Radeon X1600/X1650 PRO] [DISPLAY_VGA] (vendor:1002 device:71c6 subv:174b subd:0880)
$ lspci|fgrep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc RV530LE [Radeon X1600/X1650 PRO]
Comment 1 Thierry Vignaud 2011-08-04 23:48:49 UTC
Created attachment 49940 [details]
kernel-3.0 dmesg
Comment 2 Thierry Vignaud 2011-08-04 23:50:30 UTC
Created attachment 49941 [details]
ROM
Comment 3 Thierry Vignaud 2011-08-04 23:55:14 UTC
argh, now it works :-(


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.