Bug 39877 - Games rendered pixelated
Summary: Games rendered pixelated
Status: RESOLVED DUPLICATE of bug 39897
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-06 01:31 UTC by Alex
Modified: 2011-08-07 21:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
The main menu of the game, pixelated (331.96 KB, image/png)
2011-08-06 01:31 UTC, Alex
no flags Details
My latest Xorg.0.log (37.87 KB, patch)
2011-08-06 01:32 UTC, Alex
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2011-08-06 01:31:25 UTC
Created attachment 49984 [details]
The main menu of the game, pixelated

The title says it all.

I attached a picture of Crayon Physics Deluxe showing the issue (the linux version, not via wine).
With LIBGL_ALWAYS_INDIRECT=1 or LIBGL_ALWAYS_SOFTWARE=1, the game is correctly rendered though very slow using the software rasterizer.

I'm using Ubuntu 11.04 x86_64 with xorg-edgers packages, and I'm up-to-date.

Also, when running the game from the console, I got spammed with :
/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64
(<unknown>:4547): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

So maybe it's an issue with 32 vs 64 bits.

FYI :
alex@Leon:~$ LIBGL_DEBUG=verbose glxinfo
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/r600_dri.so

-> means symbolic link
/usr/lib/libGL.so.1 -> /usr/lib/libGL.so -> /usr/lib32/libGL.so -> /usr/lib32/mesa/libGL.so.1 -> /usr/lib32/mesa/libGL.so.1.2
alex@Leon:~$ file /usr/lib32/mesa/libGL.so.1.2 
/usr/lib32/mesa/libGL.so.1.2: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, for GNU/Linux 2.4.20, stripped

Note that I've done
/usr/lib/libGL.so.1 -> /usr/lib/libGL.so -> /usr/lib32/libGL.so
to make wine happy.
I guess for 32 bits it's ok but not for 64 bit :

/usr/lib64/libGL.so.1 -> /usr/lib64/libGL.so
alex@Leon:~$ file /usr/lib64/libGL.so
/usr/lib64/libGL.so: symbolic link to `/usr/lib32/libGL.so'

alex@Leon:~$ sudo ldconfig -p | grep libGL.so
	libGL.so.1 (libc6,x86-64, OS ABI: Linux 2.4.20) => /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1
	libGL.so.1 (libc6, OS ABI: Linux 2.4.20) => /usr/lib/libGL.so.1
	libGL.so (libc6,x86-64, OS ABI: Linux 2.4.20) => /usr/lib/x86_64-linux-gnu/libGL.so
	libGL.so (libc6,x86-64, OS ABI: Linux 2.4.20) => /usr/lib/x86_64-linux-gnu/mesa/libGL.so
	libGL.so (libc6, OS ABI: Linux 2.4.20) => /usr/lib32/libGL.so
	libGL.so (libc6, OS ABI: Linux 2.4.20) => /usr/lib/libGL.so

I know the driver is being actively developed and hacked but maybe it's related to a mis-configuration or something like that.
Comment 1 Alex 2011-08-06 01:32:10 UTC
Created attachment 49985 [details] [review]
My latest Xorg.0.log
Comment 2 Alex Deucher 2011-08-06 06:20:00 UTC
Update mesa to 7.11 or disable colortiling:
Option "ColorTiling" "False"
in the device section of your xorg conf.
Comment 3 Alex 2011-08-07 21:39:22 UTC

*** This bug has been marked as a duplicate of bug 39897 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.