Bug 40 - error at make install
Summary: error at make install
Alias: None
Product: fontconfig
Classification: Unclassified
Component: library (show other bugs)
Version: 2.1
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Keith Packard
QA Contact:
Depends on:
Reported: 2003-03-02 04:19 UTC by Vinay Pawar
Modified: 2003-04-10 22:54 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Vinay Pawar 2003-03-02 04:19:53 UTC
version 2.1.90 doesn't install properly on a LFS like system. 
It does a clean 'configure' and 'make' but fails to find libfontconfig.so.* in 
the build directory and throws an error at 'make install'.
Comment 1 Keith Packard 2003-03-04 22:15:54 UTC
Should work now that we're using vanilla libtool
Comment 2 Vinay Pawar 2003-03-24 21:32:07 UTC
Tried version 2.1.92. It still doesn't 'make install' correctly. The bug remains.
Comment 3 Keith Packard 2003-03-26 23:08:40 UTC
Please post the output from 'make' and 'make install' so I can try and figure
this out.
Comment 4 Vinay Pawar 2003-03-26 23:28:58 UTC
This is the o/p of 'make install' just before it crashes: 

if [ x = x ]; then /antomic/sources/fontconfig-2.1.92/build/usr/bin/fc-cache -f
-v; fi
/antomic/sources/fontconfig-2.1.92/build/usr/bin/fc-cache: error while loading
shared libraries: libfontconfig.so.1: cannot open shared object file: No such
file or directory
make[3]: *** [install-data-local] Error 127
Comment 5 Keith Packard 2003-04-11 15:54:45 UTC
I've switched how fc-cache is run during install to try and resolve this
problem; it runs the fc-cache wrapper script built by libtool which should find
the uninstalled version of the library correctly.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.