Bug 40026 - Build against npapi-sdk instead of xulrunner
Summary: Build against npapi-sdk instead of xulrunner
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: core (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-11 12:17 UTC by Dominique Leuenberger
Modified: 2016-01-27 21:24 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Switch to npapi (2.68 KB, patch)
2011-08-11 12:17 UTC, Dominique Leuenberger
Details | Splinter Review
D'Oh!. Of course configure.ac needs to be patched. (1.21 KB, patch)
2011-08-12 00:22 UTC, Dominique Leuenberger
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2011-08-11 12:17:09 UTC
Created attachment 50140 [details] [review]
Switch to npapi

With the new development model of firefox/xulrunner, it is impossible and unsupported by moz-devs to keep up with the changes from there.

For this reason, there are a collection of new SDK packages available now (libjs185 and npapi-sdk).

As tracking xulrunner is no longer possible, we suggest to switch to npapi:

References:
  https://wiki.mozilla.org/NPAPI
  https://developer.mozilla.org/en/Plugins
  http://code.google.com/p/npapi-sdk/

The attached patch, courtesy to Wolgang Rosenauer, changes the build system to detect npapi-sdk instead of "mozilla-plugin".

(Patch is done against 0.6.17 release)
Comment 1 Richard Hughes 2011-08-11 14:08:58 UTC
Comment on attachment 50140 [details] [review]
Switch to npapi

(In reply to comment #0)
> For this reason, there are a collection of new SDK packages available now
> (libjs185 and npapi-sdk).

Are they available in distros already?

> As tracking xulrunner is no longer possible, we suggest to switch to npapi:

Makes sense.

>diff --git a/configure b/configure
>index 12a1a4a..d8364c7 100755
>--- a/configure
>+++ b/configure
>@@ -20279,7 +20279,7 @@ if test -n "$PK_BROWSER_PLUGIN_CFLAGS"; then
>  elif test -n "$PKG_CONFIG"; then
>     if test -n "$PKG_CONFIG" && \
>     { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"\\
>-			  mozilla-plugin	\\
>+			  npapi-sdk		\\
> 			  gio-unix-2.0		\\
> 			  nspr \\
> 			  cairo			\\

You need to change configure.ac rather than the generated file.

Richard.
Comment 2 Dominique Leuenberger 2011-08-12 00:22:13 UTC
Created attachment 50152 [details] [review]
D'Oh!. Of course configure.ac needs to be patched.
Comment 3 Dominique Leuenberger 2011-08-12 00:25:10 UTC
(In reply to comment #1)
> > For this reason, there are a collection of new SDK packages available now
> > (libjs185 and npapi-sdk).
> 
> Are they available in distros already?

Any distro going forward with FF5/6/7/xxx will need them for sure. libjs185 seems already to be widely around (not of interest for us here), npapi-sdk seems to show up these days (showed up in openSUSE dev branch)

> > As tracking xulrunner is no longer possible, we suggest to switch to npapi:
> 
> Makes sense.
> 
> [...]
> 
> You need to change configure.ac rather than the generated file.

Of course. See the new patch.
Comment 4 Dominique Leuenberger 2013-01-12 12:02:30 UTC
I'm surprised to see this is not yet merged... are all distros just carrying a patch for this now?
Comment 5 Richard Hughes 2013-03-29 10:11:17 UTC
npapi-sdk doesn't seem available for me on Fedora, what package development files do I need to install?
Comment 6 Kalev Lember 2016-01-27 21:24:23 UTC
PackageKit has been able to build against npapi-sdk for a while already, nothing more to do here.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.