Bug 40063 - Xrandr panning/scaling jails the mouse
Summary: Xrandr panning/scaling jails the mouse
Status: RESOLVED DUPLICATE of bug 39949
Alias: None
Product: xorg
Classification: Unclassified
Component: App/xrandr (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Keith Packard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-13 12:36 UTC by alexanderkyte
Modified: 2011-10-06 21:02 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alexanderkyte 2011-08-13 12:36:00 UTC
http://cgit.freedesktop.org/xorg/xserver/commit/?id=56c90e29f04727c903bd0f084d23bf44eb1a0a11 Appears to be the culprit.

When using xrandr --scale, the mouse becomes constrained to a box with the original screen dimensions. This is very problematic for those of us who need to use the command to make netbooks' screens more manageable.
Comment 1 hgkamath 2011-09-15 08:44:12 UTC
perhaps Dup of Bug 39949 RandR panning doesn't work
https://bugs.freedesktop.org/show_bug.cgi?id=39949

I suspect same kind of cause, perhaps you nailed it to the applied code patch. I saw 
Mouse shouldn't move into area outside the monitors
https://bugs.freedesktop.org/show_bug.cgi?id=20334
somehow seems like a possible cause of this.
Comment 2 Paul Alesius 2011-10-06 20:40:19 UTC

*** This bug has been marked as a duplicate of bug 39949 ***
Comment 3 Paul Alesius 2011-10-06 21:02:09 UTC
I can confirm that reverting the patch fixes the mouse confinement.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.