Bug 40600 - avogadro crashes on startup due to bad target in _mesa_select_tex_object()
Summary: avogadro crashes on startup due to bad target in _mesa_select_tex_object()
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: 7.11
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords: NEEDINFO
Depends on:
Blocks:
 
Reported: 2011-09-03 05:42 UTC by paraw
Modified: 2018-03-07 04:46 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description paraw 2011-09-03 05:42:17 UTC
Upon starting avogadro, a molecular editor application for research in chemistry, the program crashes with the following output:

Mesa 7.11 implementation error: bad target in _mesa_select_tex_object()
Please report at bugs.freedesktop.org
Segmentation fault

I am not familiar with the inner workings of Mesa, but I'm following the suggestion of filing the bug here.
Comment 1 Kenneth Graunke 2011-09-03 11:04:46 UTC
I can't reproduce this.  I just installed Avogadro 1.0.3 and successfully started it with Mesa 7.11, the latest 7.11 branch, and master...all on Intel Sandybridge.

What driver are you using?  Also, can you provide a backtrace?  In particular, that should hopefully tell us (1) what OpenGL API call triggered this, and (2) what got passed as "target".
Comment 2 paraw 2011-09-03 11:47:31 UTC
My video card is a Mobility Radeon HD 4650, I'm running the closed source ATI drivers (11.8) and the classic drivers in Mesa. Backtrace follows:

#0  0x00007fffc5c68208 in _mesa_LoadMatrixd () from /usr/lib64/dri/libdricore.so
#1  0x00007ffff5f8f7eb in Avogadro::GLWidget::initializeGL (this=0x167dcd0) at /var/tmp/portage/sci-chemistry/avogadro-1.0.3-r1/work/avogadro-1.0.3/libavogadro/src/glwidget.cpp:487
#2  0x00007ffff5f86e73 in Avogadro::GLWidget::resizeEvent (this=0x167dcd0, event=0x7fffffffce30)
    at /var/tmp/portage/sci-chemistry/avogadro-1.0.3-r1/work/avogadro-1.0.3/libavogadro/src/glwidget.cpp:604
#3  0x00007ffff68d38ff in QWidget::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#4  0x00007ffff73a841a in QGLWidget::event(QEvent*) () from /usr/lib64/qt4/libQtOpenGL.so.4
#5  0x00007ffff687dcec in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#6  0x00007ffff6882fbd in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#7  0x00007ffff6382d6b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#8  0x00007ffff68d2949 in QWidgetPrivate::sendPendingMoveAndResizeEvents(bool, bool) () from /usr/lib64/qt4/libQtGui.so.4
#9  0x00007ffff68d7aa3 in QWidgetPrivate::show_helper() () from /usr/lib64/qt4/libQtGui.so.4
#10 0x00007ffff68d930a in QWidget::setVisible(bool) () from /usr/lib64/qt4/libQtGui.so.4
#11 0x00007ffff68d7f36 in QWidgetPrivate::showChildren(bool) () from /usr/lib64/qt4/libQtGui.so.4
#12 0x00007ffff68d7abf in QWidgetPrivate::show_helper() () from /usr/lib64/qt4/libQtGui.so.4
#13 0x00007ffff68d7ea0 in QWidgetPrivate::showChildren(bool) () from /usr/lib64/qt4/libQtGui.so.4
#14 0x00007ffff68d7abf in QWidgetPrivate::show_helper() () from /usr/lib64/qt4/libQtGui.so.4
#15 0x00007ffff68d930a in QWidget::setVisible(bool) () from /usr/lib64/qt4/libQtGui.so.4
#16 0x00007ffff68d7f36 in QWidgetPrivate::showChildren(bool) () from /usr/lib64/qt4/libQtGui.so.4
#17 0x00007ffff68d7abf in QWidgetPrivate::show_helper() () from /usr/lib64/qt4/libQtGui.so.4
#18 0x00007ffff68d930a in QWidget::setVisible(bool) () from /usr/lib64/qt4/libQtGui.so.4
#19 0x00007ffff68d7f36 in QWidgetPrivate::showChildren(bool) () from /usr/lib64/qt4/libQtGui.so.4
#20 0x00007ffff68d7abf in QWidgetPrivate::show_helper() () from /usr/lib64/qt4/libQtGui.so.4
#21 0x00007ffff68d930a in QWidget::setVisible(bool) () from /usr/lib64/qt4/libQtGui.so.4
#22 0x00007ffff68d7f36 in QWidgetPrivate::showChildren(bool) () from /usr/lib64/qt4/libQtGui.so.4
#23 0x00007ffff68d7abf in QWidgetPrivate::show_helper() () from /usr/lib64/qt4/libQtGui.so.4
#24 0x00007ffff68d930a in QWidget::setVisible(bool) () from /usr/lib64/qt4/libQtGui.so.4
#25 0x0000000000422b30 in main (argc=1, argv=<value optimized out>) at /var/tmp/portage/sci-chemistry/avogadro-1.0.3-r1/work/avogadro-1.0.3/avogadro/src/main.cpp:244
Comment 3 Timothy Arceri 2018-03-07 04:46:49 UTC
Since this was working for Ken in 7.11 and there have been no further reports I'm going to assume this still works. Closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.