Bug 40659 - mission-control-5 crashed with SIGSEGV in g_str_hash()
Summary: mission-control-5 crashed with SIGSEGV in g_str_hash()
Status: RESOLVED DUPLICATE of bug 40283
Alias: None
Product: Telepathy
Classification: Unclassified
Component: mission-control (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Telepathy bugs list
QA Contact: Telepathy bugs list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-06 12:31 UTC by Alexander Hunziker
Modified: 2011-09-20 00:22 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Hunziker 2011-09-06 12:31:47 UTC
Upstreaming a bug from Launchpad.net, see https://bugs.launchpad.net/ubuntu/+source/telepathy-mission-control-5/+bug/726301 for more information.

Just using empathy, moving between program windows and a crash dialog appeared.
Can't offer any useful information, sorry.

#0  g_str_hash (v=0x0) at /build/buildd/glib2.0-2.28.1/./glib/gstring.c:142
        p = 0x0
        h = 5381
#1  0x002d56d8 in g_hash_table_lookup_node (hash_table=0x91d1720, key=0x0) at /build/buildd/glib2.0-2.28.1/./glib/ghash.c:312
        node = <value optimized out>
        node_index = <value optimized out>
        hash_value = <value optimized out>
        step = 0
#2  g_hash_table_lookup (hash_table=0x91d1720, key=0x0) at /build/buildd/glib2.0-2.28.1/./glib/ghash.c:901
        node = <value optimized out>
        node_index = 152939504
        __PRETTY_FUNCTION__ = "g_hash_table_lookup"
#3  0x0807ea5c in _mcd_client_registry_lookup (self=0x91c34f0, well_known_name=0x0) at client-registry.c:179
        __PRETTY_FUNCTION__ = "_mcd_client_registry_lookup"
#4  0x08060c6b in mcd_dispatcher_client_needs_recovery_cb (client=0x91de248, self=0x91c44a0) at mcd-dispatcher.c:667
        handler = <value optimized out>
        channel = 0x91dabf0
        object_path = 0x92b5b68 "/org/freedesktop/Telepathy/Connection/gabble/jabber/paulw2u_40jabber_2eorg_2f67084fb8/ServerSASLChannel"
        properties = <value optimized out>
        hname = 0x0
        channels = <value optimized out>
        observer_filters = 0x91e7540
        list = 0x927fd50
        __PRETTY_FUNCTION__ = "mcd_dispatcher_client_needs_recovery_cb"
#5  0x00ec848c in g_cclosure_marshal_VOID__VOID (closure=0x91d3aa8, return_value=0x0, n_param_values=1, param_values=0x92436b0, invocation_hint=0xbfbdc4e0, marshal_data=0x0) at /build/buildd/glib2.0-2.28.1/./gobject/gmarshal.c:79
        callback = 0x8060b90 <mcd_dispatcher_client_needs_recovery_cb>
        cc = 0x91d3aa8
        data1 = <value optimized out>
        data2 = <value optimized out>
        __PRETTY_FUNCTION__ = "g_cclosure_marshal_VOID__VOID"
#6  0x00eac352 in g_closure_invoke (closure=0x91d3aa8, return_value=0x0, n_param_values=1, param_values=0x92436b0, invocation_hint=0xbfbdc4e0) at /build/buildd/glib2.0-2.28.1/./gobject/gclosure.c:767
        marshal = 0xec8410 <g_cclosure_marshal_VOID__VOID>
        marshal_data = 0x0
        in_marshal = 15623168
        __PRETTY_FUNCTION__ = "g_closure_invoke"
#7  0x00ebf048 in signal_emit_unlocked_R (node=0x91e0e88, detail=0, instance=0x91de248, emission_return=0x0, instance_and_params=0x92436b0) at /build/buildd/glib2.0-2.28.1/./gobject/gsignal.c:3252
        tmp = <value optimized out>
        handler = 0x91e1700
        accumulator = 0x0
        emission = {next = 0x0, instance = 0x91de248, ihint = {signal_id = 46, detail = 0, run_type = G_SIGNAL_RUN_FIRST}, state = EMISSION_RUN, chain_type = 4}
        class_closure = 0x0
        handler_list = 0x91e1700
        return_accu = 0x0
        accu = {g_type = 0, data = {{v_int = 0, v_uint = 0, v_long = 0, v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, v_pointer = 0x0}, {v_int = 0, v_uint = 0, v_long = 0, v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, v_pointer = 0x0}}}
        signal_id = 46
        max_sequential_handler_number = 874
        return_value_altered = 0
#8  0x00ec7b29 in g_signal_emit_valist (instance=0x91de248, signal_id=46, detail=0, var_args=0xbfbdc69c "2\332\352") at /build/buildd/glib2.0-2.28.1/./gobject/gsignal.c:2983
        instance_and_params = 0x92436b0
        signal_return_type = 4
        param_values = 0x92436c4
        node = 0x91e0e88
        i = <value optimized out>
        n_params = 0
        __PRETTY_FUNCTION__ = "g_signal_emit_valist"
#9  0x00ec7cc2 in g_signal_emit (instance=0x91de248, signal_id=46, detail=0) at /build/buildd/glib2.0-2.28.1/./gobject/gsignal.c:3040
        var_args = 0xbfbdc69c "2\332\352"
#10 0x0807c9d1 in mcd_client_proxy_unique_name_cb (dbus_daemon=0x91c4458, well_known_name=0x92beaec "org.freedesktop.Telepathy.Client.Logger", unique_name=0x92beb24 "", user_data=0x91de248) at mcd-client.c:997
        self = 0x91de248
        should_recover = 1
#11 0x001d069a in _tp_dbus_daemon_name_owner_changed (self=0x91c4458, name=0x92beaec "org.freedesktop.Telepathy.Client.Logger", new_owner=0x92beb24 "") at dbus-daemon.c:242
        subwatch = <value optimized out>
        watch = 0x91dd930
        array = <value optimized out>
        i = <value optimized out>
#12 0x001d0a60 in noc_idle_context_invoke (data=0x91dfba8) at dbus-daemon.c:315
        iter = 0x91b88d0
        context = 0x91dfba8
        name = 0x92beaec "org.freedesktop.Telepathy.Client.Logger"
        old_owner = 0x92beb18 ":1.1391"
        new_owner = 0x92beb24 ""
        dbus_error = {name = 0x0, message = 0x0, dummy1 = 1, dummy2 = 0, dummy3 = 0, dummy4 = 0, dummy5 = 0, padding1 = 0x0}
        daemons = <value optimized out>
        __PRETTY_FUNCTION__ = "noc_idle_context_invoke"
#13 0x002e2451 in g_idle_dispatch (source=0x91d7ab0, callback=0x1d0960 <noc_idle_context_invoke>, user_data=0x91dfba8) at /build/buildd/glib2.0-2.28.1/./glib/gmain.c:4537
No locals.
#14 0x002e6c08 in g_main_dispatch (context=0x91c2be0) at /build/buildd/glib2.0-2.28.1/./glib/gmain.c:2440
        dispatch = 0x2e2430 <g_idle_dispatch>
        was_in_call = 0
        user_data = 0x91dfba8
        callback = 0x1d0960 <noc_idle_context_invoke>
        cb_funcs = 0x37c33c
        cb_data = 0x92a6970
        current_source_link = {data = 0x91d7ab0, next = 0x0}
        need_destroy = <value optimized out>
        source = 0x91d7ab0
        current = 0x91d6e40
        i = <value optimized out>
#15 g_main_context_dispatch (context=0x91c2be0) at /build/buildd/glib2.0-2.28.1/./glib/gmain.c:3013
No locals.
#16 0x002e73d0 in g_main_context_iterate (context=0x91c2be0, block=1, dispatch=1, self=<value optimized out>) at /build/buildd/glib2.0-2.28.1/./glib/gmain.c:3091
        max_priority = -100
        timeout = 0
        some_ready = 1
        nfds = <value optimized out>
        allocated_nfds = <value optimized out>
        fds = 0x91e3a10
#17 0x002e7a93 in g_main_loop_run (loop=0x91c6a60) at /build/buildd/glib2.0-2.28.1/./glib/gmain.c:3299
        __PRETTY_FUNCTION__ = "g_main_loop_run"
#18 0x08054d30 in mcd_service_run (self=0x91c6c18) at mcd-service.c:196
No locals.
#19 0x08052a67 in main (argc=1, argv=0xbfbdc9c4) at mc-server.c:78
        mcd = 0x91c6c18
Comment 1 Xavier Claessens 2011-09-20 00:22:15 UTC

*** This bug has been marked as a duplicate of bug 40283 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.