Bug 40972 - Codecs installation not working
Summary: Codecs installation not working
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-17 10:04 UTC by Bastien Nocera
Modified: 2011-09-18 07:14 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
pk logs (8.23 KB, text/plain)
2011-09-17 10:04 UTC, Bastien Nocera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bastien Nocera 2011-09-17 10:04:43 UTC
Created attachment 51294 [details]
pk logs

With the zif backend, after launching a video with missing codecs in Totem, I don't get any single window telling me what's happening.
Comment 1 Richard Hughes 2011-09-18 00:55:35 UTC
Eek, this is an internal error in Zif, where the ZifState is not correct (ZifState works out global percentage changed in an accurate way).

I can't reproduce here with git master of each, but what version of zif and PackageKit have you got installed please.

I think this crash is probably fixed by my commit a few days ago:

commit 7d616c24aa222d04781e15ba5e6c57f4f3de6351
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Sep 7 16:17:09 2011 +0100

    zif: Fix a critical warning when using WhatProvides

If you've got a couple of minutes, can you try rebuilding the f15 PackageKit srpm here http://people.freedesktop.org/~hughsient/fedora/15/SRPMS/ and installing the build rpms using rpm -Fvh *.rpm

Thanks.

Richard.
Comment 2 Bastien Nocera 2011-09-18 02:03:20 UTC
PackageKit-zif-0.6.18-2.fc16.x86_64
zif-0.2.3-1.fc16.x86_64

Testing the package now.
Comment 3 Bastien Nocera 2011-09-18 02:21:19 UTC
Updtaed zif seems to have done it.
Comment 4 Richard Hughes 2011-09-18 06:45:24 UTC
Cool, new upstream release in a couple of weeks, and I'll push to Fedora then. Thanks.
Comment 5 Bastien Nocera 2011-09-18 07:14:09 UTC
(In reply to comment #4)
> Cool, new upstream release in a couple of weeks, and I'll push to Fedora then.
> Thanks.

Before F16 gold I hope :)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.