Bug 40973 - pkcon needs "yum-builddep" equivalent
Summary: pkcon needs "yum-builddep" equivalent
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-17 10:24 UTC by Bastien Nocera
Modified: 2011-10-04 06:51 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bastien Nocera 2011-09-17 10:24:14 UTC
Otherwise I need to use yum, instead of my preferred zif backend.
Comment 1 Richard Hughes 2011-09-19 04:57:15 UTC
To do this for pkcon we would need new DBus API which we've already half-discussed on the mailing list. When we've come to some kind of decision on how to implement it, it'll be easy to add the zif parts. Other distros actually have the build-depends for the source package much easier (e.g. gentoo) but others like apt it's much harder.

In the meantime, I've added a new subcommand to zif:

commit 818b454c6e098715f2f5cdf001c272aa6c62e2b8
Author: Richard Hughes <richard@hughsie.com>
Date:   Sun Sep 18 14:56:07 2011 +0100

    Add a new command 'build-depends' to install packages needed to build other packages
    
    Resolves https://bugs.freedesktop.org/show_bug.cgi?id=40973

:100644 100644 9920f5a... bf008a9... M  tools/zif-main.c

I think punting this to the zif command line is okay for the moment, as programmers using the command line will want package build-depends, and we don't actually need it in any GUI or interactive programs just yet.

If you could checkout zif from git master and give it a try I'd be most grateful. Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.