Bug 41061 - Xrandr probing slow unless HDMI1 disabled
Summary: Xrandr probing slow unless HDMI1 disabled
Status: RESOLVED DUPLICATE of bug 41059
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.6 (2010.12)
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Chris Wilson
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-09-20 16:19 UTC by Bryce Harrington
Modified: 2011-09-22 14:46 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
BootDmesg.txt (59.43 KB, text/plain)
2011-09-20 16:19 UTC, Bryce Harrington
no flags Details
CurrentDmesg.txt (2.74 KB, text/plain)
2011-09-20 16:20 UTC, Bryce Harrington
no flags Details
XorgLog.txt (37.52 KB, text/plain)
2011-09-20 16:20 UTC, Bryce Harrington
no flags Details
Xrandr.txt (5.58 KB, text/plain)
2011-09-20 16:23 UTC, Bryce Harrington
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2011-09-20 16:19:38 UTC
Forwarding this boot speed related regression from Ubuntu reporter Hernando Torque (htorque):

     https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/855133

[Problem]
Regression starting in 2.6.39-05 kernel that causes xrandr probing to take several seconds.  If HDMI1 is disable, previous boot speed is restored.


[Original Report]
Starting with Ubuntu's kernel 2.6.39-0.5, xrandr probing takes a couple of seconds with only one output connected (internal LCD of ThinkPad T510).

This probing also negatively influences lightdm (see bug 828112).

Comment #11 in that bug report suggests to ignore HDMI outputs via xorg.conf, which actually restores the behavior of older kernels and running 'xrandr' becomes a lot faster (in my case it's sufficient to just ignore HDMI1).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Wed Sep 21 00:19:18 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.2, 2.6.38-11-generic, x86_64: installed
 virtualbox, 4.1.2, 2.6.38-8-generic, x86_64: installed
 virtualbox, 4.1.2, 3.0.0-11-generic, x86_64: installed
 virtualbox, 4.1.2, 3.1.0-999-generic, x86_64: installed
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21d9]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110112)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 003: ID 046d:c048 Logitech, Inc. G9 Laser Mouse
MachineType: LENOVO 4349WK7
PlymouthDebug: Error: [Errno 13] Permission denied: '/var/log/plymouth-debug.log'
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=755daaa3-ddf9-4451-ad6d-2b5354cee2c2 ro quiet splash elevator=deadline bootchart=disable vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/29/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6MET75WW (1.35 )
dmi.board.name: 4349WK7
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6MET75WW(1.35):bd09/29/2010:svnLENOVO:pn4349WK7:pvrThinkPadT510:rvnLENOVO:rn4349WK7:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4349WK7
dmi.product.version: ThinkPad T510
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.5.94+bzr20110919-0ubuntu1~ppa1
version.ia32-libs: ia32-libs 20090808ubuntu22
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1
Comment 1 Bryce Harrington 2011-09-20 16:19:58 UTC
Created attachment 51435 [details]
BootDmesg.txt
Comment 2 Bryce Harrington 2011-09-20 16:20:12 UTC
Created attachment 51436 [details]
CurrentDmesg.txt
Comment 3 Bryce Harrington 2011-09-20 16:20:26 UTC
Created attachment 51437 [details]
XorgLog.txt
Comment 4 Bryce Harrington 2011-09-20 16:23:20 UTC
Created attachment 51438 [details]
Xrandr.txt
Comment 5 Bryce Harrington 2011-09-20 16:26:58 UTC
This bug I'm guessing is a dupe of #41059.  It likely also needs to have the phantom HDMI1 output quirked off or something.  But the interesting bit is that this user narrowed the regression to occurring between kernels  2.6.38-8.42 → good, 2.6.39-0.5 → bad

He also confirmed it is still happening with a daily upstream kernel (ubuntu mainline ppa) from 201108310919.
Comment 6 Eugeni Dodonov 2011-09-22 14:46:53 UTC
Looks like a dupe of bug #41059 indeed, so I'll close this one and leave the other.

*** This bug has been marked as a duplicate of bug 41059 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.