Bug 41102 - [sandybridge-m-gt2] IPEHR: 0xff2c001e [garbage in batch]
Summary: [sandybridge-m-gt2] IPEHR: 0xff2c001e [garbage in batch]
Status: CLOSED DUPLICATE of bug 29046
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.6 (2010.12)
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Chris Wilson
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-21 20:20 UTC by Bryce Harrington
Modified: 2016-11-03 12:09 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
XorgLog.txt (49.95 KB, text/plain)
2011-09-21 20:21 UTC, Bryce Harrington
no flags Details
i915_error_state.txt (2.05 MB, text/plain)
2011-09-21 20:21 UTC, Bryce Harrington
no flags Details
CurrentDmesg.txt (5.26 KB, text/plain)
2011-09-21 20:21 UTC, Bryce Harrington
no flags Details
BootDmesg.txt (62.35 KB, text/plain)
2011-09-21 20:21 UTC, Bryce Harrington
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2011-09-21 20:20:20 UTC
Forwarding this bug from Ubuntu reporter Jiri Techet:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/855054

[Problem]
GPU lockup while running firefox.

[Original Description]
Happened while browsing the web with firefox. Suddenly everything (like the menu bar, launcher and window decoration) except for firefox tabs and the window with web page disappeared. When the PC's power button was pressed, a dialog with shutdown options appeared and it was possible to restart the computer normally.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
.tmp.unity.support.test.0:
 
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Chipset: sandybridge-m-gt2
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Tue Sep 20 22:36:39 2011
DistUpgraded: Log time: 2011-08-26 20:23:04.337565
DistroCodename: oneiric
DistroVariant: ubuntu
DuplicateSignature: [sandybridge-m-gt2] GPU lockup  render.IPEHR: 0x02000002 Ubuntu 11.10
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GpuHangFrequency: Very infrequently
GpuHangReproducibility: Seems to happen randomly
GpuHangStarted: I don't know
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21ce]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110803.1)
InterpreterPath: /usr/bin/python2.7
MachineType: LENOVO 41786NG
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:
 
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=9c19aa40-5ce3-4be6-8e4e-7703f5912065 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg             1:7.6+7ubuntu7
 libdrm2                  2.4.26-1ubuntu1
 xserver-xorg-video-intel 2:2.15.901-1ubuntu2
SourcePackage: xserver-xorg-video-intel
Title: [sandybridge-m-gt2] GPU lockup  render.IPEHR: 0x02000002
UpgradeStatus: Upgraded to oneiric on 2011-09-12 (8 days ago)
UserGroups:
 
dmi.bios.date: 07/29/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 83ET63WW (1.33 )
dmi.board.asset.tag: Not Available
dmi.board.name: 41786NG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr83ET63WW(1.33):bd07/29/2011:svnLENOVO:pn41786NG:pvrThinkPadT420:rvnLENOVO:rn41786NG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 41786NG
dmi.product.version: ThinkPad T420
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.5.94+bzr2803-0ubuntu5
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1
Comment 1 Bryce Harrington 2011-09-21 20:21:09 UTC
Created attachment 51496 [details]
XorgLog.txt
Comment 2 Bryce Harrington 2011-09-21 20:21:23 UTC
Created attachment 51497 [details]
i915_error_state.txt
Comment 3 Bryce Harrington 2011-09-21 20:21:34 UTC
Created attachment 51498 [details]
CurrentDmesg.txt
Comment 4 Bryce Harrington 2011-09-21 20:21:44 UTC
Created attachment 51499 [details]
BootDmesg.txt
Comment 5 Chris Wilson 2011-09-22 08:09:00 UTC
Smells like bug 41098.
Comment 6 Chris Wilson 2012-03-26 01:44:50 UTC
I believe these are all related to the underlying bug:

commit c501ae7f332cdaf42e31af30b72b4b66cbbb1604
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Wed Dec 14 13:57:23 2011 +0100

    drm/i915: Only clear the GPU domains upon a successful finish
    
    By clearing the GPU read domains before waiting upon the buffer, we run
    the risk of the wait being interrupted and the domains prematurely
    cleared. The next time we attempt to wait upon the buffer (after
    userspace handles the signal), we believe that the buffer is idle and so
    skip the wait.
    
    There are a number of bugs across all generations which show signs of an
    overly haste reuse of active buffers.
    
    Such as:
    
      https://bugs.freedesktop.org/show_bug.cgi?id=29046
      https://bugs.freedesktop.org/show_bug.cgi?id=35863
      https://bugs.freedesktop.org/show_bug.cgi?id=38952
      https://bugs.freedesktop.org/show_bug.cgi?id=40282
      https://bugs.freedesktop.org/show_bug.cgi?id=41098
      https://bugs.freedesktop.org/show_bug.cgi?id=41102
      https://bugs.freedesktop.org/show_bug.cgi?id=41284
      https://bugs.freedesktop.org/show_bug.cgi?id=42141
    
    A couple of those pre-date i915_gem_object_finish_gpu(), so may be
    unrelated (such as a wild write from a userspace command buffer), but
    this does look like a convincing cause for most of those bugs.
    
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Cc: stable@kernel.org
    Reviewed-by: Daniel Vetter <daniel.vetter@ffwll.ch>
    Reviewed-by: Eugeni Dodonov <eugeni.dodonov@intel.com>
    Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Comment 7 Gordon Jin 2012-04-01 01:58:47 UTC
to mark dup to show relationship

*** This bug has been marked as a duplicate of bug 29046 ***
Comment 8 Jari Tahvanainen 2016-11-03 12:09:24 UTC
Closing resolved+duplicate as duplicate of closed+fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.