Bug 41219 - test-corrupt has undeclared dependency on GLib 2.26 and leaks refs
Summary: test-corrupt has undeclared dependency on GLib 2.26 and leaks refs
Status: RESOLVED FIXED
Alias: None
Product: dbus
Classification: Unclassified
Component: core (show other bugs)
Version: 1.4.x
Hardware: Other All
: medium normal
Assignee: Simon McVittie
QA Contact: John (J5) Palmieri
URL: http://cgit.freedesktop.org/~smcv/dbu...
Whiteboard: review+
Keywords: patch
Depends on:
Blocks: dbus-1.4
  Show dependency treegraph
 
Reported: 2011-09-26 03:33 UTC by Simon McVittie
Modified: 2011-11-02 10:04 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
corrupt test: compile successfully against older GLib (Debian stable) (3.39 KB, patch)
2011-09-26 10:14 UTC, Simon McVittie
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Simon McVittie 2011-09-26 03:33:59 UTC
We could bump the dependency in configure.ac to 2.26, but that breaks compilation on (for instance) Debian stable, and we don't really need g_socket_send_with_blocking here anyway.
    
Also, don't leak the GLib socket objects.
Comment 1 Simon McVittie 2011-09-26 10:14:24 UTC
Created attachment 51639 [details] [review]
corrupt test: compile successfully against older GLib (Debian stable)

We don't really need g_socket_send_with_blocking here.

Also, don't leak the GLib socket objects.
Comment 2 Lennart Poettering 2011-11-01 09:14:33 UTC
Uh, really evil, but given that this is a just a test looks good and does the job.
Comment 3 Simon McVittie 2011-11-02 10:04:28 UTC
Thanks, fixed in git for 1.4.18, 1.5.10


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.