Bug 41368 - TypeError: this._accountManager.get_factory is not a function, breaks gnome-shell 3.2.0
Summary: TypeError: this._accountManager.get_factory is not a function, breaks gnome-s...
Status: RESOLVED FIXED
Alias: None
Product: Telepathy
Classification: Unclassified
Component: tp-glib (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium critical
Assignee: Telepathy bugs list
QA Contact: Telepathy bugs list
URL: http://cgit.collabora.com/git/user/xc...
Whiteboard:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2011-09-30 12:02 UTC by Ionut Biru
Modified: 2011-10-03 04:48 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ionut Biru 2011-09-30 12:02:04 UTC
Upgrading to telepathy-glib 0.15.6 breaks gnome-shell 3.2.0 and the fail whale window appear.

xsession-errors has this error:

JS ERROR: !!!   Exception was: TypeError: this._accountManager.get_factory is not a function
    JS ERROR: !!!     lineNumber = '124'
    JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/telepathyClient.js"'
    JS ERROR: !!!     stack = '"()@/usr/share/gnome-shell/js/ui/telepathyClient.js:124
Client()@/usr/share/gnome-shell/js/ui/telepathyClient.js:77
_createUserSession()@/usr/share/gnome-shell/js/ui/main.js:84
start()@/usr/share/gnome-shell/js/ui/main.js:223
@<main>:1
"'
    JS ERROR: !!!     message = '"this._accountManager.get_factory is not a function"'



Only 0.15.5 works with gnome-shell 3.2.0
Comment 1 Jan Alexander Steffens (heftig) 2011-09-30 12:18:01 UTC
Seems this is caused by commit 4899882 "Sort alphabetically introspected files". Revert it and the problem disappears.

I think proxy.c needs to be first. Maybe there also are other dependencies in the old order?
Comment 2 Ionut Biru 2011-10-01 06:33:21 UTC
i reported upstream to glib as well
Comment 3 Xavier Claessens 2011-10-03 01:13:40 UTC
(In reply to comment #2)
> i reported upstream to glib as well

For the record, it is bug #660629
Comment 4 Xavier Claessens 2011-10-03 01:14:42 UTC
(In reply to comment #3)
> For the record, it is bug #660629

https://bugzilla.gnome.org/show_bug.cgi?id=660629
Comment 5 Xavier Claessens 2011-10-03 04:41:03 UTC
ok, let's revert for now:

http://cgit.collabora.com/git/user/xclaesse/telepathy-glib.git/log/?h=fix-gi
Comment 6 Xavier Claessens 2011-10-03 04:48:09 UTC
merged. Will release 0.15.7 asap


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.