Bug 41375 - VDPAU not working on RS880
Summary: VDPAU not working on RS880
Status: CLOSED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-30 18:40 UTC by Mike Lothian
Modified: 2013-11-26 10:05 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg (38.13 KB, text/plain)
2011-09-30 18:40 UTC, Mike Lothian
Details
Xorg.0.log (36.73 KB, text/plain)
2011-09-30 18:40 UTC, Mike Lothian
Details
mplayer2 log (4.02 KB, text/plain)
2011-09-30 18:41 UTC, Mike Lothian
Details
Screen shot of garbled picture (1.22 MB, image/jpeg)
2011-09-30 18:43 UTC, Mike Lothian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Lothian 2011-09-30 18:40:00 UTC
Created attachment 51826 [details]
dmesg

VDPAU playback on Mplayer or Mplayer2 with ffmpeg or libav produces garbled images - this also happens when using xv on the Xorg state tracker too

I'm attaching system logs and the output from mplayer2 

Mplayer2 crashes when it gets to the end of the video
Comment 1 Mike Lothian 2011-09-30 18:40:52 UTC
Created attachment 51828 [details]
Xorg.0.log
Comment 2 Mike Lothian 2011-09-30 18:41:17 UTC
Created attachment 51829 [details]
mplayer2 log
Comment 3 Mike Lothian 2011-09-30 18:43:54 UTC
Created attachment 51831 [details]
Screen shot of garbled picture
Comment 4 Mike Lothian 2011-09-30 18:49:01 UTC
I start smplayer with LD_LIBRARY_PATH=/usr/lib/vdpau VDPAU_DRIVER=r600 smplayer

If there is anything else I can provide to help debug this please let me know

the sample mpeg video is 29MB let me know if you'd like me to upload it somewhere

It does play fine using xv using the regular DDX it's only vdpau or xv under the xorg state tracker where the video doesn't display properly
Comment 5 Andy Furniss 2011-10-01 11:02:40 UTC
(In reply to comment #0)
> Created an attachment (id=51826) [details]
> dmesg
> 
> VDPAU playback on Mplayer or Mplayer2 with ffmpeg or libav produces garbled
> images - this also happens when using xv on the Xorg state tracker too

I believe RS880 3d parts are rv6xx - my rv670 has produced garbled output since March. My rv790 is unaffected.

If your issue is the same one, then the devs are aware from feedback given on the mesa-dev list.

> Mplayer2 crashes when it gets to the end of the video

There has been a more recent regression that causes me to see the same with mplayer svn but not release mplayer. It also only affects some vids. This is also known via the list.
Comment 6 Christian König 2013-11-25 12:49:50 UTC
I just tested in on an RS880 and it works fine.

Any objections on closing this bug?
Comment 7 Mike Lothian 2013-11-25 12:57:53 UTC
I'll test it when I get home tonight. I take it its software vdpau. Is it
only mpeg2 that's implemented?
On 25 Nov 2013 12:49, <bugzilla-daemon@freedesktop.org> wrote:

>  Christian König <deathsimple@vodafone.de> changed bug 41375<https://bugs.freedesktop.org/show_bug.cgi?id=41375>
>  What Removed Added  Status NEW RESOLVED  Resolution --- WORKSFORME
>
>  *Comment # 6 <https://bugs.freedesktop.org/show_bug.cgi?id=41375#c6> on
> bug 41375 <https://bugs.freedesktop.org/show_bug.cgi?id=41375> from
> Christian König <deathsimple@vodafone.de> *
>
> I just tested in on an RS880 and it works fine.
>
> Any objections on closing this bug?
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You are the assignee for the bug.
>
>
> _______________________________________________
> dri-devel mailing list
> dri-devel@lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/dri-devel
>
>
Comment 8 Alex Deucher 2013-11-25 18:43:03 UTC
(In reply to comment #7)
> I'll test it when I get home tonight. I take it its software vdpau. Is it
> only mpeg2 that's implemented?

It's shader based decode for mpeg2.
Comment 9 Mike Lothian 2013-11-26 00:10:26 UTC
It is indeed working - it's just a lot slower than xv

Fingers crossed that UVD support is added for the RS880 one day


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.