Bug 41427 - butterfly fails to reconnect after suspend/resume
Summary: butterfly fails to reconnect after suspend/resume
Status: RESOLVED DUPLICATE of bug 37672
Alias: None
Product: Telepathy
Classification: Unclassified
Component: butterfly (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Telepathy bugs list
QA Contact: Telepathy bugs list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-03 10:42 UTC by Frederik Himpe
Modified: 2012-07-21 03:53 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frederik Himpe 2011-10-03 10:42:53 UTC
Very often after a suspend/resume cyle during which empathy was still 
connected to MSN, Empathy refuses to re-establish the connection, until I 
kill the mission-control and telepathy-butterfly processes.

The mission-control log contains this:
mcd-WARNING: 02/10/11 20:03:52.288355: request_connection_cb: RequestConnection failed:
org.freedesktop.DBus.Python.KeyError: Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.6/dist-packages/telepathy/server/connmgr.py", line 96, in RequestConnection
    conn = self._protos[proto](self, parameters)
  File "/usr/lib/python2.6/dist-packages/butterfly/protocol.py", line 160, in create_connection
    return ButterflyConnection(self, connection_manager, parameters)
  File "/usr/lib/python2.6/dist-packages/butterfly/connection.py", line 89, in __init__
    'butterfly', protocol)
  File "/usr/lib/python2.6/dist-packages/telepathy/server/conn.py", line 85, in __init__
    _Connection.__init__(self, bus_name, object_path)
  File "/usr/lib/python2.6/dist-packages/dbus/service.py", line 480, in __init__
    self.add_to_connection(conn, object_path)
  File "/usr/lib/python2.6/dist-packages/dbus/service.py", line 571, in add_to_connection
    self._fallback)
KeyError: "Can't register the object-path handler for
'/org/freedesktop/Telepathy/Connection/butterfly/msn/login_40example_2ecom': there is
already a handler"

The butterfly log contains:
butterfly/connection-INFO: 02/10/11 20:03:16.954375: Using direct proxy: None
butterfly/connection-INFO: 02/10/11 20:03:17.20596: Using http proxy: None
butterfly/connection-INFO: 02/10/11 20:03:17.21298: Using https proxy: None
papyon/papyon.msnp2p.transport-INFO: 02/10/11 20:03:17.148885: Registering transport
<NotificationP2PTransport object at 0x18eb960 (papyon+msnp2p+transport+base+BaseP2PTransport
at 0x18c4f60)>
butterfly/connection-ERROR: 02/10/11 20:03:17.210047: Failed to create Connection
butterfly/connection-INFO: 02/10/11 20:03:52.240566: Using direct proxy: None
butterfly/connection-INFO: 02/10/11 20:03:52.242748: Using http proxy: None
butterfly/connection-INFO: 02/10/11 20:03:52.245244: Using https proxy: None
papyon/papyon.msnp2p.transport-INFO: 02/10/11 20:03:52.276025: Registering transport
<NotificationP2PTransport object at 0x18f5870 (papyon+msnp2p+transport+base+BaseP2PTransport
at 0x1923380)>
butterfly/connection-ERROR: 02/10/11 20:03:52.282108: Failed to create Connection

I am using these versions on Debian Wheezy AMD64:

ii  libmission-control-plugins0                  1:5.9.0-1                         management daemon for Telepathy (library for plugins)
ii  libtelepathy-farsight0                       0.0.19-1                          Glue library between telepathy and farsight2
ii  libtelepathy-glib0                           0.15.5-1                          Telepathy framework - GLib library
ii  libtelepathy-glib0-dbg                       0.15.5-1                          GLib Telepathy library (debug symbols)
ii  python-telepathy                             0.15.19-2.1                       Python language bindings for telepathy
ii  remmina-plugin-telepathy                     0.9.2-2+b1                        Telepathy plugin for remmina remote desktop client
ii  telepathy-butterfly                          0.5.15-2.1                        MSN connection manager for Telepathy
ii  telepathy-gabble                             0.13.5-1                          Jabber/XMPP connection manager
ii  telepathy-mission-control-5                  1:5.9.0-1                         management daemon for Telepathy real-time communication framework
ii  telepathy-salut                              0.5.0-3                           Link-local XMPP connection manager for the Telepathy framework
ii  telepathy-sofiasip                           0.7.1-2                           SIP connection manager for the Telepathy framework
Comment 1 Jean-François Fortin Tam 2012-07-21 03:53:08 UTC

*** This bug has been marked as a duplicate of bug 37672 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.