Bug 42384 - X fails on NV11 with Error allocating scanout buffer: 0
Summary: X fails on NV11 with Error allocating scanout buffer: 0
Status: VERIFIED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-29 12:40 UTC by Chris Paulson-Ellis
Modified: 2012-01-12 14:13 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg log (16.47 KB, text/plain)
2011-10-29 12:40 UTC, Chris Paulson-Ellis
no flags Details
kernel log (58.08 KB, text/plain)
2011-10-29 12:42 UTC, Chris Paulson-Ellis
no flags Details
xorg config (90 bytes, text/plain)
2011-10-29 12:43 UTC, Chris Paulson-Ellis
no flags Details
dmesg for working config (59.05 KB, text/plain)
2011-10-30 09:07 UTC, Chris Paulson-Ellis
no flags Details
xorg log for working config (29.64 KB, text/plain)
2011-10-30 09:08 UTC, Chris Paulson-Ellis
no flags Details
working xorg config (208 bytes, text/plain)
2011-10-30 09:09 UTC, Chris Paulson-Ellis
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Paulson-Ellis 2011-10-29 12:40:57 UTC
Created attachment 52902 [details]
xorg log

Hi,

I have an old Geforce2Go card (NV11). The nouveau framebuffer is working fine (KMS enabled), but X won't start with the nouveau driver (it's okay with fbdev):

[    54.231] (II) NOUVEAU(0): Opened GPU channel 1
[    54.231] (II) NOUVEAU(0): [DRI2] Setup complete
[    54.231] (II) NOUVEAU(0): [DRI2]   DRI driver: nouveau_vieux
[    54.231] (II) NOUVEAU(0): [DRI2]   VDPAU driver: nouveau_vieux
[    54.233] (EE) NOUVEAU(0): Error allocating scanout buffer: 0
[    54.233] 
Fatal server error:
[    54.233] AddScreen/ScreenInit failed for driver 0

I'm on Fedora 15 and I have tried with the latest packaged driver and with a build of xf86-video-nouveau from git.

xf86-video-nouveau: git 29 Oct 2011
libdrm-2.4.26-1.fc15.i686
xorg-x11-server-Xorg-1.10.4-1.fc15.i686

I'm not interested in 3D, but I can't work out if there's something I've failed to disable. If you need me to enable more debug, please point to some instructions on how to do this.

dmesg, Xorg logs & cfg attached.

Regards,
Chris.
Comment 1 Chris Paulson-Ellis 2011-10-29 12:42:27 UTC
Created attachment 52903 [details]
kernel log
Comment 2 Chris Paulson-Ellis 2011-10-29 12:43:04 UTC
Created attachment 52904 [details]
xorg config
Comment 3 Marcin Slusarz 2011-10-29 13:10:12 UTC
Does it work if you lower bpp/resolution for framebuffer and/or xserver?
Comment 4 Marcin Slusarz 2011-10-30 03:55:48 UTC
On Sat, Oct 29, 2011 at 11:26:59PM +0100, Chris Paulson-Ellis wrote:
> On 29/10/11 22:06, Chris Paulson-Ellis wrote:
> > On 29/10/11 14:10, bugzilla-daemon@freedesktop.org wrote:
> >> https://bugs.freedesktop.org/show_bug.cgi?id=42384
> >>
> >> --- Comment #3 from Marcin Slusarz<marcin.slusarz@gmail.com>  
> >> 2011-10-29 13:10:12 UTC ---
> >> Does it work if you lower bpp/resolution for framebuffer and/or xserver?
> >>
> >
> > Can't get bugzilla to work for this comment at present,...

Then please CC bugzilla-daemon@freedesktop.org - mails will be automatically
appended to bugreport.

> > Yes. It works if I reduce the framebuffer and the X server to 800x600 
> > 16bpp. Just reducing to 16bpp doesn't work. Just changing the X server 
> > doesn't work, I have to change the framebuffer too.
> >
> > The card has 64MiB.

Nouveau detects only 16 MB of VRAM. Can you verify it by looking at the card?
According to http://www.nvidia.com/page/geforce2go.html there were 16, 32
and 64 MB versions of GeForce2 Go.

Very similar bug was reported few months ago:
http://lists.freedesktop.org/archives/nouveau/2011-July/008631.html

Can you test patch (hack) posted there?

> I can also get it to work using "NoAccel", including at full 1600x1200, 
> depth 24, although obviously with fbdev-like performance.

Note: that's almost half of your VRAM.

Marcin
Comment 5 Chris Paulson-Ellis 2011-10-30 09:06:24 UTC
You're absolutely right. The VRAM is 16Mb. I was misled by the GART aperture being 64Mb.

No need for the hack. I managed to get it working by setting the framebuffer to 8bpp at the lowest resolution listed in the modelines from the Xorg log (640x350). I can then get X working at full resolution as long as I use 16bpp. These together account for <4Mb, so something is being profligate with the VRAM, but it works, so I'm happy. Thankyou for your help.

For the record, I put the following on the end of the kernel line in grub.conf:
    video=LVDS-1:640x350-8

and my xorg.conf looks like this:

Section "Device"
        Identifier      "n"
        Driver          "nouveau"
EndSection

Section "Screen"
        Identifier      "n"
        Device          "n"
        DefaultDepth    16

        SubSection "Display"
                Depth   16
                Modes   "1600x1200"
        EndSubSection
EndSection

I'll attach new logs.
Comment 6 Chris Paulson-Ellis 2011-10-30 09:07:22 UTC
Created attachment 52921 [details]
dmesg for working config
Comment 7 Chris Paulson-Ellis 2011-10-30 09:08:24 UTC
Created attachment 52922 [details]
xorg log for working config
Comment 8 Chris Paulson-Ellis 2011-10-30 09:09:11 UTC
Created attachment 52923 [details]
working xorg config
Comment 9 Chris Paulson-Ellis 2011-10-30 09:12:14 UTC
I'm willing to do testing if you want to make changes to make cards such as mine work out of the box, but I'm guessing you've got bigger fish to fry than to worry about such ancient hardware!

Many thanks for your efforts on the driver.

Chris.
Comment 10 Francisco Jerez 2011-11-06 12:57:05 UTC
(In reply to comment #9)
> I'm willing to do testing if you want to make changes to make cards such as
> mine work out of the box, but I'm guessing you've got bigger fish to fry than
> to worry about such ancient hardware!
> 
> Many thanks for your efforts on the driver.
> 
> Chris.

Thanks for reporting, this should be fixed now with the latest nouveau kernel module (commit http://cgit.freedesktop.org/nouveau/linux-2.6/commit/?id=787ffe1f651ce3af0d90040ec1c93f0ad177b3de).
Comment 11 Chris Paulson-Ellis 2011-11-07 20:00:39 UTC
I can confirm that with this fix (and everything else in the current nouveau linux git tree), I can now boot without a kernel command line video= parameter and without an xorg.conf.

Both the framebuffer and the X server use the full 1600x1200 of my laptop panel and X creates a 24 bit depth display.

Many thanks again,
Chris.
Comment 12 David Mackenzie 2011-11-28 12:14:20 UTC
I have this same problem. How can I install this patch? Do you know when it will make it into the ubuntu edgers binaries?
Comment 13 Florian Mickler 2012-01-12 14:13:16 UTC
A patch referencing this bug report has been merged in Linux v3.2-rc2:

commit 4beb116a454867cc3a98d02d906e0f0459aefe72
Author: Francisco Jerez <currojerez@riseup.net>
Date:   Sun Nov 6 21:21:28 2011 +0100

    drm/nv10: Change the BO size threshold determining the memory placement range.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.