Bug 42423 - make default Korean font from Un to Nanum
Summary: make default Korean font from Un to Nanum
Status: RESOLVED FIXED
Alias: None
Product: fontconfig
Classification: Unclassified
Component: conf (show other bugs)
Version: 2.8
Hardware: All All
: medium enhancement
Assignee: Keith Packard
QA Contact: Behdad Esfahbod
URL:
Whiteboard:
Keywords: patch
: 45335 45613 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-31 05:13 UTC by Jinkyu Yi
Modified: 2012-02-20 22:38 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
patch to add Nanum Korean fonts (2.87 KB, application/octet-stream)
2011-10-31 05:13 UTC, Jinkyu Yi
Details
add Nanum fonts, fix Baekmuk missing, fix monospace priority (2.85 KB, patch)
2012-02-10 07:03 UTC, Jinkyu Yi
Details | Splinter Review
add Nanum fonts, fix Baekmuk missing, fix monospace priority (2.85 KB, patch)
2012-02-13 06:53 UTC, Jinkyu Yi
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jinkyu Yi 2011-10-31 05:13:11 UTC
Created attachment 52946 [details]
patch to add Nanum Korean fonts

at 2008, new free Korean font, Nanum came with OFL license(free license).
And, Nanum family fonts are having much better quility than Un family's.
As the result, Mac OS 10.7(codename Lion) and ChromeOS decide to include Nanum fonts.
So, I suggest to use Nanum instead of Un.

Nanum has several Korean fonts, iincluding sans, serif, and monospace.
NanumGothic is Korean sans-serif font, NanumMyeongjo is Korean serif font, and NanumGothic is Korean monospace font.

I attach patch file.
Also I add some more comment(<!-- hangul (ko) -->) and change priority at monosapce in 65-nonlatin.conf.
Comment 1 Akira TAGOH 2011-11-09 01:12:34 UTC
just for reference on this moving:
http://permalink.gmane.org/gmane.linux.ubuntu.devel.discuss/13090
Comment 2 Changwoo Ryu 2012-01-31 09:36:23 UTC
*** Bug 45335 has been marked as a duplicate of this bug. ***
Comment 3 Jinkyu Yi 2012-02-04 07:34:30 UTC
*** Bug 45613 has been marked as a duplicate of this bug. ***
Comment 4 Jinkyu Yi 2012-02-10 07:03:51 UTC
Created attachment 56872 [details] [review]
add Nanum fonts, fix Baekmuk missing, fix monospace priority
Comment 5 Felix Geyer 2012-02-13 03:25:05 UTC
There is a small syntax error in the patch:

+			<family>Baekmuk Gulim</family <!-- hangul (ko) -->
should be
+			<family>Baekmuk Gulim</family> <!-- hangul (ko) -->
Comment 6 Jinkyu Yi 2012-02-13 06:53:53 UTC
Created attachment 56971 [details] [review]
add Nanum fonts, fix Baekmuk missing, fix monospace priority

Ah, thanks Felix!
Comment 7 Akira TAGOH 2012-02-20 22:38:08 UTC
Fixed in 8c58dc27.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.