Bug 42516 - Assertion `src.File != TGSI_FILE_NULL' failed with llvmpipe renderer
Summary: Assertion `src.File != TGSI_FILE_NULL' failed with llvmpipe renderer
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: 7.11
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact:
Depends on:
Blocks: 42517
  Show dependency treegraph
Reported: 2011-11-02 07:25 UTC by Christian Holler (:decoder)
Modified: 2012-12-11 23:26 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

Test case for Firefox using llvmpipe as WebGL renderer (4.37 KB, text/html)
2011-11-02 07:25 UTC, Christian Holler (:decoder)
Archive containing API trace files (10.77 KB, application/x-compressed-tar)
2011-11-09 03:16 UTC, Christian Holler (:decoder)

Description Christian Holler (:decoder) 2011-11-02 07:25:18 UTC
Created attachment 53058 [details]
Test case for Firefox using llvmpipe as WebGL renderer

I'm using the llvmpipe software renderer to test WebGL in Firefox. The attached html testcase crashes my Firefox with the following assertion:

src/gallium/auxiliary/tgsi/tgsi_ureg.c:800:ureg_emit_src: Assertion `src.File != TGSI_FILE_NULL' failed.
Trace/breakpoint trap

Sometimes I had to load the test several times for the assertion to trigger. The large JavaScript parts in the beginning of the test are leftovers from the test harness of the WebGL test suite (this is a mutation test derived from a WebGL conformance test).

Version information from glxinfo:

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe
OpenGL version string: 2.1 Mesa 7.11
OpenGL shading language version string: 1.20

If you need the full output, let me know.
Comment 1 Jose Fonseca 2011-11-02 08:12:52 UTC
Could you try to obtain a trace of the GL calls with apitrace for this case, per https://github.com/apitrace/apitrace/blob/master/README.markdown

That would help alot.
Comment 2 Christian Holler (:decoder) 2011-11-09 03:16:32 UTC
Created attachment 53320 [details]
Archive containing API trace files

Attached is a .tgz containing firefox.trace and firefox.1.trace (both files generated from one run). Let me know if you need further information :)
Comment 3 Brian Paul 2011-11-10 13:45:36 UTC
I tried your traces with llvmpipe (as of today) and didn't see any failed assertions.  I also tried the Mesa 7.11 branch it no assertions there either.

Could you try current Mesa/llvmpipe from git?
Comment 4 Brian Paul 2012-12-11 23:26:38 UTC
There hasn't been any follow-up about testing something newer than Mesa 7.11 and I don't see the problem with later versions.  Closing.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.